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Signal Generator Features
Signal Generator Features
• N5181A, analog models: 250 kHz to 1, 3, or 6 GHz

N5182A, vector models: 250 kHz to 3 or 6 GHz

• electronic attenuator

• step & list sweep of frequency, power, or frequency and power

vector models can include waveforms in list sweep

• user flatness correction

• automatic leveling control (ALC); power calibration

• 10 MHz reference oscillator with external output

• flexible reference input, 1 – 50 MHz (Option 1ER)

• GPIB, USB 2.0, and 100Base- T LAN interfaces

• analog modulation: AM, FM, and ΦM (Option UNT)

• external AM, FM, and ΦM inputs (Option UNT)

• pulse modulation (Option UNU)

• SCPI and IVI- COM driver 

• 8648/ESG code compatible

• LXI Class C compliant

• external analog I/Q inputs (vector models)

• analog differential I/Q outputs (vector models, Option 1EL)

• arbitrary I/Q waveform playback up to 125 MSa/s (vector models, Option 654)

• with Signal Studio Software, vector models can generate 802.11 WLAN, W- CDMA, cdma2000, 
1xEV- DO, GSM, EDGE, and more

For more details on hardware, firmware, software, and documentation features and options, refer to 
the data sheet shipped with the signal generator and available from the Agilent Technologies website. 

1. Open: http://www.agilent.com/find/mxg

2. Select the desired model number.

3. In the options and price list section, click price list.
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Front Panel Overview
Front Panel Overview

1. Host USB

Use this universal serial bus (USB) to connect a memory stick for data transfer. You can connect or 
disconnect a USB device without shutting down or restarting the signal generator. The instrument 
also has a rear- panel device USB connector (see page 11) used to remotely control the instrument.

2. Display

The LCD screen provides information on the current function. Information can include status 
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located 
on the right- hand side of the display. See also, “Front Panel Display” on page 7.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign 
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 24.

5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing. 
See “Entering and Editing Numbers and Text” on page 24.

Connector Type A

USB Protocol 2.0

22. Power Switch and LEDs 

21. More and LED 

20. Return 

18. Knob 

19. Incr Set 
15. Page Down 

16. I Input 

17. Q Input 

12. RF 
Output 

13. RF On/Off and LED 

14. Mod On/Off and LED 

7. MENUS 
and
10. Help 

11. Preset 
and User 
Preset 

9. Local 
Cancel/(Esc) 

5. Arrows and Select 

6. Page Up 

8. Trigger 

4. Numeric 
Keypad 3. Softkeys 2. Display 1. Host USB 

MXG Vector Signal Generator
N5181A 250 kHz - 6 GHz
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Front Panel Overview
6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on 
page 25. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Down key (page 5) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access 
information.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a 
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control, 
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on 
page 23.

11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user- defined). See “Presetting 
the Signal Generator” on page 23.

See page 42

See page 38

See page 35

See page 26

See page 53

See page 57

Active only on 
vector models.

See page 26

See page 27

See page 15

See page 23

See page 67

Reserved for 
future use.
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Front Panel Overview
12. RF Output

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The 
RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation 
format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on 
page 34).

The MOD ON/OFF LED lights when modulation of the output is enabled.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on 
page 25. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Up key (page 4) to scroll text.

16. I Input (vector models only)

See also, “I/Q Modulation” on page 121.

17. Q Input (vector models only)

See also, “I/Q Modulation” on page 121.

Connector Standard:
Option 1EM:
Impedance:

female Type- N
Rear panel female Type- N
50Ω

Damage Levels 50Vdc, 2W maximum RF power

Connector Type: female BNC Impedance: 50Ω
Signal An externally supplied analog, in- phase component of I/Q modulation.

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1Vrms

Connector Type: female BNC Impedance: 50Ω
Signal An externally supplied analog, quadrature- phase component of I/Q modulation.

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1Vrms
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Front Panel Overview
18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit, 
character, or item in a list. See also, “Front Panel Knob Resolution” on page 17.

19. Incr Set 

This hardkey enables you to set the increment value of the currently active function. The increment 
value also affects how much each turn of the knob changes an active function’s value, according to 
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 17).

20. Return 

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key 
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More 
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED 
lights and all signal generator functions deactivate. The signal generator remains connected to the 
line power, and some power is consumed by some internal circuits. In the on position, the green LED 
lights and the signal generator functions activate.
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Front Panel Display
Front Panel Display

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the 
current frequency setting appears. If the currently active function has an increment value associated 
with it, that value also appears. 

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error 
conditions. An annunciator position may be used by more than one annunciator; in this case, only 
one of the functions sharing a given position can be active at a given time.

This annunciator appears when . . .

ΦM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ΦM.

ARB The ARB generator is on.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and 
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at 
temperature.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

5. Error Message Area 6. Text Area 7. Softkey Label Area 

4. Amplitude Area 3. Annunciators 2. Frequency Area 1. Active Function Area 

Scroll Bar
If there is more 
text than can be 
displayed on one 
screen, a scroll 
bar appears here. 
Use the Page Up 
and Page Down 
keys to scroll 
through the text.
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Front Panel Display
4. Amplitude Area

This area displays the current output power level setting.

5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent 
message remains displayed. See “Reading Error Messages” on page 42.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other 
information such as sweep lists and file catalogs. This area also enables you to perform functions 
such as managing information (entering information, and displaying or deleting files).

7. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of 
the display. Softkey labels change, depending on the function selected.

DIGBUS The digital bus is in use.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of 
the error messages or clear the error queue (see “Reading Error Messages” on page 42).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ΦM annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or 
VXI- 11/Sockets (LAN) interface.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 51).

OFFS An output offset is set (see “Setting an Output Offset” on page 49).

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI- 11/Sockets (LAN) interface.

REF An output reference is set (see “Setting an Output Reference” on page 50).

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI- 11/Sockets (LAN) 
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI- 11/Sockets 
(LAN) interface.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of 
instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF, 
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the 
error messages (see “Reading Error Messages” on page 42).

WINIT The signal generator is waiting for you to initiate a single sweep.

This annunciator appears when . . .
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Rear Panel Overview
Rear Panel Overview

1. AC Power Receptacle

The AC power cord receptacle accepts a three- pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the 
Installation Guide.

2. SWEEP OUT

3. AM

Connector female BNC
Can drive 2 kΩ.

Impedance <1Ω

Signal Voltage range: 0 to +10V, regardless of sweep width
In swept mode: beginning of sweep = 0V; end of sweep = +10V
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 33 and 57.

Connector female BNC Impedance nominally 50Ω
Signal An externally supplied ±1Vp signal that produces the indicated depth.

Damage Levels 5Vrms and 10Vp

2. SWEEP OUT 

3. AM 

4. FM 

5. PULSE 

6. TRIG IN 

7. TRIG OUT 

8. REF IN 

10. GPIB 

11. LAN 

12. Device USB 

9. 10 MHz OUT 

Digital Modulation Connectors (vector models only) on page 12 1. AC Power Receptacle 

Option 1EM
only 

See page 5
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Rear Panel Overview
4. FM

5. PULSE

6. TRIG IN

7. TRIG OUT

8. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this connector 
and automatically switch from internal to external reference operation. See “Presetting the Signal 
Generator” on page 23. With Option 1ER (flexible reference input), you must explicitly tell the signal 
generator the external reference frequency you wish to use; enter the information through the front 
panel or over the remote interface.

Connector female BNC Impedance nominally 50Ω
Signal An externally supplied ±1Vp signal that produces the indicated deviation

Damage Levels 5Vrms and 10Vp

Connector female BNC Impedance nominally 50Ω
Signal Externally supplied: +1V = on; 0V = off 

Damage Levels 5Vrms and 10Vp

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as 
point- to- point in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5V and ≥ +5.5V

Connector female BNC Impedance nominally 50Ω
Signal A TTL signal that is high at the start of a dwell sequence, or when waiting for the point 

trigger in manual sweep mode. 
It is low when the dwell is over, or when the point trigger is received. 
The logic polarity can be reversed.

This is a multiple use connector. For signal routing selections, see pages 33 and 57.

Connector female BNC Impedance nominally 50Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is 

within ±1 ppm.
10 Agilent N5181A/82A MXG Signal Generators User’s Guide



Signal Generator Overview
Rear Panel Overview
9. 10 MHz OUT

10. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 11. LAN and 
12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector, 
which enables a LAN- connected computer to remotely program the signal generator. The LAN 
interface is LXI class C compliant; it does not support auto−MDIX. The signal generator is limited to 
100 meters on a single cable (100Base- T). For more information on the LAN, refer to the 
Programming Guide.

12. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

Connector female BNC Impedance nominally 50Ω
Signal A nominal signal level greater than 4 dBm.

Connector Mini- B

USB Protocol Version 2.0
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Digital Modulation Connectors (vector models only)

I OUT, QOUT,  OUT,  OUT

EXT CLOCK

EVENT 1

Connector Type: female BNC Impedance: 50Ω
DC- coupled

Signal

I OUT The analog, in- phase component of I/Q modulation from the internal baseband generator.

Q OUT The analog, quadrature- phase component of I/Q modulation from the internal baseband 
generator.

 OUT Used in conjunction with the I OUT connector to provide a balanceda baseband stimulus.

aBalanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity 
(180 degrees out of phase).

 OUT Used in conjunction with the Q OUT connector to provide a balanceda baseband stimulus.

Damage Levels > 1 Vrms DC Origin Offset typically <10 mV

Output Signal Levels into a 50Ω Load

• 0.5Vpk, typical, corresponds to one unit length of the I/Q vector

• 0.69Vpk (2.84 dB), typical, maximum crest factor for peaks for π/4 DQPSK, alpha = 0.5

• 0.71Vpk (3.08 dB), typical, maximum crest factor for peaks for π/4 DQPSK, alpha = 0.35

• Typically 1Vp- p maximum

Connector female BNC Impedance nominally 50Ω

Signal An externally supplied TTL or CMOS bit clock signal where the rising edge aligns with the 
beginning data bit. 
The falling edge is used to clock external signals.
This signal is used with digital modulation applications.

Damage Levels > +8 and < −4V Maximum Clock Rate 50 MHz

Connector female BNC Impedance: nominally 50Ω

Signal A pulse that can be used to trigger the start of a data pattern, frame, or timeslot. 
Adjustable to ± one timeslot; resolution = one bit
Markers
Each Arb- based waveform point has a marker on/off condition associated with it. 
Marker 1 level = +3.3V CMOS high (positive polarity selected); –3.3V CMOS low (negative 
polarity selected). 
Output on this connector occurs whenever Marker 1 is on in an Arb- based waveform (see 
“Using Waveform Markers” on page 82).

Damage Levels >+8 and <−4V

I Q

I

Q
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Signal Generator Overview
Rear Panel Overview
PAT TRIG IN

DIGITAL BUS I/O

This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not 
operational for general purpose use. Signals are present only when a signal creation software option 
is installed (for details, refer to http://www.agilent.com/find/signalcreation).

AUX I/O

Connector female BNC Impedance: nominally 50Ω

Signal A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger. 
The input to this connector triggers the internal digital modulation pattern generator to start a 
single pattern output or to stop and re- synchronize a pattern that is being continuously output. 
To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled 
during the falling edge of the internal data bit clock. 
This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse Width (high or low) = 100 ns

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods

Damage Levels > +8 and < −4V

View looking into rear panel female 50-pin connector
25 1

2650

Pin 1 = Event 1
Pin 2 = Event 2
Pin 3 = Event 3
Pin 4 = Event 4
Pin 5 = Sample Rate Clock Out
Pin 6 = Patt Trig In 2

Pins 7–25 = Reserved*

Pins 26–50 = Ground

*Future Capability

Event 1, 2, 3, and 4 (pins 1 − 4)
A pulse that can be used to trigger the start of a data pattern, frame, or timeslot. 
Adjustable to ± one timeslot; resolution = one bit

Markers
Each Arb-based waveform point has a marker on/off condition associated with it. 
Marker level = +3.3V CMOS high (positive polarity selected); –3.3V CMOS low (negative polarity selected).

Output on these pins occurs whenever the corresponding marker is on in an Arb-based waveform (see “Using Waveform Markers” on 
page 82).

Patt Trig In 2 (pin 6)
A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger. 
The input to this connector triggers the internal digital modulation pattern generator to start a single pattern output or to stop and 
re-synchronize a pattern that is being continuously output. 

To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled during the falling edge of the internal data bit 
clock. 

This is an external trigger for all ARB waveform generator triggers. Minimum pulse width = 100 ns. Damage levels: > +5.5 and < −0.5V.

Sample Rate Clock Out (pin 5)
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data. 
Damage levels: > +5.5 and < −0.5V.
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Signal Generator Overview
Rear Panel Overview
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2 Setting Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus in 
which you can enable instrument options.

page 16

Front Panel Knob Resolution on page 17

page 17

Enabling an Option on page 21

Configuring the GPIB Interface on page 19

Configuring the LAN Interface on page 20

Enabling LAN Services: Browser, Sockets, and VXI-11 on page 20

User Preferences

Remote Operation 

Setting Time and Date on page 18

Upgrading Firmware on page 18
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Setting Preferences & Enabling Options
User Preferences
User Preferences
From the Utility menu, you can set the following user preferences:

• Display Settings, below

• Power On and Preset on page 17

• Front Panel Knob Resolution on page 17

Display Settings

NOTE With both brightness and contrast set to minimum, the display may be too dark to see the 
softkeys. If this happens, use the figure above to locate the brightness and contrast softkeys 
and adjust their values so that you can see the display.

Range: 15—100

Range: 35—55

Range: 1—12 hours, in 1 hour increments

Light Only: turns the display light off, leaving the text visible at a low intensity. 

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to 
prevent the text from burning the display.

When on, commands executed through 
the remote control bus update the signal 
generator display accordingly.

Bright without color

Utility > Display >

See also, Using the Secure Display (Option 006 Only) on page 

For details on each key, use key help
as described on page 23.

page 137

Dark text on a light 
background.

Light text on a dark 
background.
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Setting Preferences & Enabling Options
User Preferences
Power On and Preset

Front Panel Knob Resolution

Select the GPIB language desired after a preset.
See also, the Programming Guide and the SCPI Reference.

Utility > Power On/Preset >

Restores persistent settings 
(those unaffected by a power 
cycle, preset, or recall)

Available only when 8648 is either the selected preset language, or 
the selected GPIB remote language (see page 19).

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.

Makes the increment value of the current function the active entry.

Utility > 
Instrument Adjustments >

The increment value and the step/knob ratio determine how much each 
turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the 
step/knob ratio is 50 to 1, each turn of the knob changes the active 
function by 0.2 dB (1/50th of 10 dB). 

To change the amount for each turn of the knob, modify the increment 
value, the step/knob ratio, or both.

For details on each key, use key help
as described on page 23.
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Setting Preferences & Enabling Options
Upgrading Firmware
Setting Time and Date

The signal generator’s firmware tracks the 
time and date, and uses the latest date 
and time that has been set as its time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time- based licenses, 
and that you are resetting the signal generator’s time/date reference point. When you set a new time 
or date that is later than the signal generator’s current reference point, that date becomes the new 
reference point. If you then set the date back, you run the risk described in the next section.

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the 
reference point (the latest date that has been set). If you set the time back more than approximately 
25 hours, you disable the signal generator’s ability to use time- based licenses, even if there is no 
license installed at the time that you set the time back. In this case, you can reenable the signal 
generator’s ability to use time- based licenses by returning the date to within 25 hours prior to the 
the reference point, or to anytime after the reference point.

If you find you must set the date backward more than approximately 25 hours (when, for example, 
the time is mistakenly set ahead) and you wish to use time- based licenses, you must contact Agilent 
Technologies for assistance (see page 151).

Upgrading Firmware
For information on new firmware releases, go to http://www.agilent.com/find/upgradeassistant.

Changing the time or date can 
adversely affect the signal 
generator’s ability to use time−based 
licenses, even if a time−based 
license is not installed when you 
change the time or date.

Utility > 
Instrument Adjustments >CAUTION

Original time/date reference point

Time

New time/date reference point

Point at which the signal generator can 
no longer use time-based licenses.

Time

Current time/date reference point

> 25 hours
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Setting Preferences & Enabling Options
Remote Operation Preferences
Remote Operation Preferences
For details on operating the signal generator remotely, refer to the Programming Guide.

Configuring the GPIB Interface

page 20

Below

page 20

NOTES

USB is also available. It is not shown in the menu because it requires no 
configuration.

For details on using the instrument remotely, see the Programming Guide.

Select the desired GPIB language.

Utility > I/O Config >

For details on each key, use key help
as described on page 23.
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Setting Preferences & Enabling Options
Remote Operation Preferences
Configuring the LAN Interface

Enabling LAN Services: Browser, Sockets, and VXI-11

NOTES
Use a 100Base-T LAN cable to connect the 
signal generator to the LAN. 

Use a crossover cable to connect the signal 
generator directly to a PC.

For details on using the instrument remotely, see 
the Programming Guide.

Utility > I/O Config >

See page 20

Listed in the 
Programming Guide

Enable remote (browser) access to 
the instrument’s file system.

Use a browser to control the signal generator.

Utility > I/O Config >

For details on each key, use key help
as described on page 23.
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Setting Preferences & Enabling Options
Enabling an Option
Enabling an Option
There are two ways to enable an option: 

• Use the License Manager software utility:

1. Download the utility from www.agilent.com/find/LicenseManager 

2. Run the utility and follow the prompts.

• Use SCPI commands, as described in the Programming Guide.

Viewing Options and Licenses

Utility > 
Instrument Info >

Service Software Licenses 

Waveform licenses from some 
Instrument options appear 
here. A check mark means that 
an option is enabled.

For details on each key, use key help
as described on page 23.

Signal Studio applications appear here.

appear here.
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Setting Preferences & Enabling Options
Enabling an Option
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3 Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation, 
refer to the Programming Guide.

• Presetting the Signal Generator, below

• Viewing Key Descriptions, below

• Entering and Editing Numbers and Text on page 24

• Setting Frequency and Power (Amplitude) on page 26

• Configuring a Swept Output on page 27

• Modulating the Carrier Signal on page 34

• Viewing, Saving, and Recalling Data on page 35

• Reading Error Messages on page 42

Presetting the Signal Generator

Viewing Key Descriptions

To return the signal generator to a known state, press either Preset or User Preset.

Preset is the factory preset; User Preset is a custom preset* (see also, page 17). 

To reset persistent settings (those unaffected by preset, user preset, or power cycle),
press: Utility > Power On/Preset > Restore System Defaults.

*You can create more than one user preset by giving each saved state file a different name (see Figure 3-6 on page 40).

The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key.
The help displays and the key’s normal function does not execute.
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Basic Operation
Entering and Editing Numbers and Text
Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Entering Alpha Characters

Data entry softkeys appear in 
various menus. If their meaning 
is not clear in context, use the 
help key (described on page 23) 
to display an explanation. Use 
the softkey next to the alpha 
table for help on the table.

Selecting data that accepts 
alpha characters, displays one of 
the menus shown at right.

Use the arrow keys or knob to 
highlight the desired letter, then 
press the Select hardkey (or the 
softkey next to the alpha table). 
To correct errors, use Bk Sp or 
Clear Text.

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the 
letters A through F (use the numeric keypad for other values).

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

To specify a negative value, enter the
negative sign either before or after

Backspace moves the cursor to the left,
deleting characters as it goes.

Left/right arrow keys move the cursor horizontally.

Page up/down keys move tables of data up and down within the display area.

 

Use the number keys and decimal point to enter numeric data.

Note: Rotating the knob increases or
decreases a numeric value, changes a 
highlighted digit or character, or steps 
through lists or items in a row.

See also, Front Panel Knob Resolution on page 19

the numeric value (this key is a toggle).

For details on each key, see page 23.

Use the Select hardkey to choose part of an entry, as when entering alpha 
characters. In some menus, the Select key also acts as a terminator, and is 
equivalent to the Enter softkey.

to move the cursor 
within the active value 
rather than within the 
alpha table, turn the 
alpha table off.

Add/edit comments for saved 
instrument state files (see page 38).

Note: File names are limited to 25 characters.
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Basic Operation
Entering and Editing Numbers and Text
Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor 
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.

2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor. 

4. (Optional) Display the selected item in the active function area: Press Select.

5. Modify the value:

• If the value is displayed in the active function area, use the knob, arrow keys, or numeric 
keypad to modify the value.

• If the value is not displayed in the active function area, use the numeric keypad to enter the 
desired value (which then appears in the active function area).

6. Terminate the entry:

• If available, press the desired units.
• If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.

Cursor

Table Editor Softkeys Table Editor Name Table Items

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable) 
item, either press Select, or simply enter the desired value.

Table items are also 
called data fields.

Used to load, navigate, modify, and 
store table item values. For details 
on each key, use the key help: 
Press the Help hardkey and then 
the desired key.

Active Function Area

Current / Total Number of Pages

Indicates that 
another menu 
is available; to 
display the 
second menu, 
press More.

(vector models only)
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Basic Operation
Setting Frequency and Power (Amplitude)
Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output
1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the 
front panel display areas are shown on page 7).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz. 

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the active 
entry area.

3. Set the amplitude to −20 dBm: Press Amptd > –20 > dBm.

The display changes to −20 dBm in the AMPLITUDE area of the display, and the amplitude value 
becomes the active entry. Amplitude remains the active function until you press another function 
key.

4. Turn on the RF Output: Press RF On/Off.

The RF Output LED lights, and a 700 MHz, −20 dBm CW signal is available at the RF OUTPUT 
connector.

 

See
page 47

Option 
1ER only

To display the next menu, press More.

page 44

For details on each key, use key help
as described on page 23.
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Basic Operation
Configuring a Swept Output
Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude points:

Step sweep (page 28) provides a linear or logarithmic progression from one selected frequency, or 
amplitude, or both to another, pausing at linearly or logarithmically spaced points (steps) along the 
sweep. The sweep can progress forward, backward, or manually. 

List sweep (page 29) enables you to enter frequencies and amplitudes at unequal intervals, in 
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current 
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep 
data in the file catalog (page 37).

Figure 3-2 Sweep Softkeys

Sweep without waiting for 
a trigger at each point. 
Point Trigger pauses for the dwell 
time prior to the first sweep.

Apply a TTL/CMOS signal to the 
Trigger In connector.

Periodically issue a trigger event to 
whatever selects it as a source.

Using timer trigger with single 
sweep results in a delay prior to the 
first sweep.

Trigger on a remote command.

Down sweeps from 
stop to start 
frequency/amplitude.

Up sweeps from start 
to stop 
frequency/amplitude.

See page 28

See 
page 29

The selected sweep type determines the displayed parameter.

Available when 
Sweep Type = List

See 
page 33

During a frequency sweep, the CW frequency does not display; for an amplitude sweep, the amplitude does not display; 
for a frequency and amplitude sweep, neither frequency nor amplitude displays.

Progress Bar: very fast sweeps can 
appear to sweep randomly or backward.

See page 33

For details on each key, use key help as described on page 23.
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Basic Operation
Configuring a Swept Output
Step Sweep

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or 
both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The 
sweep can progress forward, backward, or manually. 

Example: Configuring a Continuous, Linear Step Sweep

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step spacing 
selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd Off On.

A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude. 
The SWEEP annunciator displays, both the CW frequency and the amplitude display blank 
(indicating that both are sweeping), and the progress bar shows the sweep progress.

5. Turn the RF output on: Press RF On/Off. 

The RF LED lights, and the continuous sweep is available at the RF Output connector.

Output: A signal that continuously sweeps from 500 to 600 MHz and from −20 to 0 dBm, with a 
dwell time of 500 ms at each of six equally−spaced points.

Start frequency 500 MHz: Press Freq Start > 500 > MHz

Stop frequency 600 MHz: Press Freq Stop > 600 > MHz

Amplitude at the beginning of the sweep, −20 dBm: Press Amptd Start > −20 > dBm

Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.

6 sweep points: Press # Points > 6 > Enter

Dwell time at each point, 500 milliseconds: Press More > Step Dwell > 500 > msec

Dwell Time = the time that the signal is settled and you can make 
a measurement before the sweep moves to the next point.

(Point-to-point time is the sum of the value set for the dwell plus 
processing time, switching time, and settling time.) 

Lin = steps equally spaced over the sweep; the output changes 
linearly.

Log = step spacing increases logarithmically over the sweep; the 
output changes exponentially.

Step Sweep and List Sweep dwell times are set independently.

For details on each key, use key help
as described on page 23.
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Basic Operation
Configuring a Swept Output
List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear 
ascending, descending, or random order. List sweep also enables you to copy the current step sweep 
values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file 
catalog (page 37). Dwell time is editable at each point.

Figure 3-3 List Sweep Configuration Softkeys and Display

see page 30

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell 
time is the same at each point; List Sweep dwell time can be different at each point.

Dwell Time = the time that the signal is settled and you can make a measurement before the 
sweep moves to the next point.

Point-to-Point Time = the sum of the value set for the dwell plus processing time, switching 
time, and settling time. 

Each line defines the 
corresponding point in 
the sweep. For example, 
line 1 defines point 1.

See page 28

Available only on vector models, 
and 
only when Sweep Type = List.

Displays the selected 
sweep type parameters 
(see page 30)

Vector models only

See page 33

For details on each key, use key help
as described on page 23.

Available only when 
waveform entry is selected
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Basic Operation
Configuring a Swept Output
Example: Configuring a List Sweep Using Step Sweep Data
1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep 

configured on page 28.

2. In the SWEEP menu, change the sweep type to list: 
Press SWEEP > Sweep Type List Step to highlight List. 

The display shows sweep list parameters, as shown below.

3. Open the List Sweep menu: Press More > Configure List Sweep.

4. Clear any previously set values from the menu and load the points defined in the step sweep into 
the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset. 

The display updates with the values loaded from the step sweep, as shown.

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the 
SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off. 
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

Vector Models:

Presetting the list clears 
any previously selected 
waveforms. 

For information on 
selecting a list sweep 
waveform, see Example: 
Editing List Sweep 
Points on page 31.

Waveforms are available 
only on vector models.
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Basic Operation
Configuring a Swept Output
Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 25.

1. Create the desired list sweep. This example uses the list sweep created in the previous example.

2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error. 

3. Set the sweep type to list: Press SWEEP > Sweep Type List Step to highlight List. 

4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row. 

This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.

7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row 
5, then press More > Insert Item.

This shifts the original frequency values for rows 5 and 6 down one row, and creates an entry for 
row 8 that contains only a frequency value (the power and dwell time entries do not shift down).

8. Change the still- active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5 
is now the active parameter.

9. Insert a new power value (−2.5 dBm) for point 5, and shift down the original power values for 
points 5 and 6 by one row: Press Insert Item > −2.5 > dBm. 

10. To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy 
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

11. For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12. Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform.
The signal generator displays the available waveforms, as shown in the following example.

b. Highlight the desired waveform (in this example, SINE_TEST) and press either the Select 
hardkey or the Select Waveform softkey.

Either select a waveform,

or 

select no modulation.
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Basic Operation
Configuring a Swept Output
13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The 
following figure shows an example of how this might look.

14. Turn sweep on: 
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15. If it is not already on, turn the RF output on: 
Press RF On/Off. 

The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping, 
and the progress bar shows the progression of the sweep. 

Example: Using a Single Sweep
1. Set up either a step sweep (page 28) or a list sweep (page 30).

2. In the List/Sweep menu, set the sweep repeat to single: 
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to 
be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.

4. Initiate the sweep: Press Single Sweep.

A single repetition of the configured sweep is available at the RF Output connector. 

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the 
progress bar shows the progression of the sweep. 

At the end of the single sweep, there is no progress bar, and the WINIT annunciator replaces 
SWEEP.

The empty entry is equivalent to 
choosing CW (no modulation).
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Basic Operation
Configuring a Swept Output
Example: Manual Control of Sweep
1. Set up either a step sweep (page 28) or a list sweep (page 30).

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter.

3. Select manual mode: Press Return > More > Manual Mode Off On.

4. If it is not already on, turn the RF output on: Press RF On/Off.

5. Select the point to output: Press Manual Point > number > Enter.

6. Use the knob or arrow keys to move from point to point.

Routing Signals

Sweep > More > More > Route Connectors >

The parameters of the selected sweep point define 
the signal available at the RF Output connector.

When you enter the manual 
point, the progress bar moves to 
and stops at the selected point.

The SWMAN annunciator 
indicates that the sweep 
is in manual mode.

Select the signal that you want routed 
to each output connector.

For details on each key, use key help
as described on page 23.
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Modulating the Carrier Signal
Modulating the Carrier Signal
To modulate the carrier signal, you must have both 

• an active modulation format
and

• modulation of the RF output enabled

Example
1. Preset the signal generator.

2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating 
that a modulation format is active.

3. Enable modulation of the RF output: Press the Mod On/Off key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not 
modulate until you subsequently turn on a modulation format.

NOTE To turn modulation off, press the Mod On/Off key until the LED turns off.

When the Mod On/Off key is off, the carrier signal is not modulated, even with an active 
modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/Off key until 
the LED lights.

See also: “Using Analog Modulation (Option UNT Only)” on page 53
“Using Pulse Modulation (Option UNU)” on page 57
“I/Q Modulation” on page 121

 

Annunciator indicates active AM modulation

AM modulation format on.

A lit LED indicates that any 
active modulation format can 
modulate the carrier.
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Viewing, Saving, and Recalling Data
Viewing, Saving, and Recalling Data
The signal generator enables you to store data as files and view those files in a file catalog. From the 
File Catalog (shown in Figure 3- 4), you can delete, copy, or rename a stored file.

• Viewing a Stored File on page 36

• Saving and Recalling Data on page 37

See also:

Working with Instrument State Files on page 38

Selecting Internal or External Media on page 41

Storing, Loading, and Playing a Waveform Segment on page 70.

Figure 3-4 File Softkeys

Instrument operating parameters (see page 38).

Sweep data from the List Mode Values table editor.

User flatness calibration corrections.

See page 136

Note: Available file types depend on the installed options.

Waveform files and their associated marker 
and header information.

Note:
If you open the External Media menu without external 
USB media connected, the signal generator displays 
the message External Media Not Detected.

See page 41

For details on each key, use key help
as described on page 23.
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Basic Operation
Viewing, Saving, and Recalling Data
Viewing a Stored File

Files Stored in the Signal Generator
1. Press File > Catalog Type > desired catalog.

The files in the catalog appear in alphabetical order. File information includes the file:

• name

• type

• size

• modification date and time

Files Stored on External Media
1. Connect the external media.

The instrument displays the External Media directory.

2. Highlight the USER directory and press Select.

The file directories on the external media appear in alphabetical order, as shown in the following 
figure.

Use the Page Up and Page Down 
keys to see the contents of the 
USER directory.
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Viewing, Saving, and Recalling Data
Saving and Recalling Data

The method of storing and recalling data depends on the data.

• An instrument state file contains instrument settings. For this type of file, use the Save and Recall 
hardkeys, shown in Figure 3- 5 on page 38.

• For other types of data, use the Load/Store softkeys (shown below) that are available through the 
menu used to create the file. 

NOTE File names are limited to 25 characters.

Use this menu to enter the file name, 
as described on page 24.For details on each key, use key help

as described on page 23.
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Basic Operation
Viewing, Saving, and Recalling Data
Working with Instrument State Files

Figure 3-5 Save and Recall Softkeys

Example: Saving an Instrument State
1. Preset the signal generator and set the following:

2. (Optional, vector models only) Associate a waveform file with these settings: 

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first 

move it from internal or external media to BBG media, see page 71. 

3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.

4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg. 

If a waveform is currently selected, saving the instrument state also saves the waveform file 
name. 

5. Add a descriptive comment to sequence 1 register 01: 

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in 
the Saved States list when you press Recall. If the instrument state has an associated waveform, 
entering the waveform name makes it easy to identify which instrument state applies to which 
waveform. 

The following information is not stored in a state file:

System Security Level List Mode Freq Hostname Remote Language FM Deviation

System Security Level Display List Mode Power IP Address FTP Server PM Deviation

System Security Level State List Mode Dwell Subnet Mask Manual DHCP MAC

Web Server (HTTP) List Mode Sequence Default Gateway VXI- 11 SCPI User Power Correction

Sockets SCPI (TELNET) Display State On/Off ARB Files List Files I/Q Calibration Data

• Frequency: 800 MHz • Amplitude: 0 dBm • RF: on

Instrument settings (states) save to instrument state 
memory, which is divided into 10 sequences (0 through 9); 
each sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you 
to delete the contents of a specific register, or the contents 
of all sequences in the state file catalog. 

The signal generator requires that you confirm a deletion.

For details on each key, use key help
as described on page 23.
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Basic Operation
Viewing, Saving, and Recalling Data
Example: Recalling an Instrument State
1. Preset the signal generator.

2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored in the 
registers in that sequence; RECALL Reg is the active entry. 

3. Select the desired instrument state: 

If the desired state is listed in the currently selected sequence, press desired number > Enter.
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.

Example: Recalling an Instrument State and Associated Waveform File 
1. Recall the desired instrument state (see previous example).

2. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.

The name is displayed as the selected waveform. Recalling the instrument state recalls only the 
waveform name. It does not recreate the waveform file if it was deleted, or load the file into BBG 
media if it is in internal or external media.

3. Ensure that the desired waveform file exists, and that it is in BBG media (page 71). If the 
waveform file is not in BBG media, performing the next step generates an error. 

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Example: Recalling an Instrument State and Associated List File 

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency 
and/or amplitude values. Because you must load the list file from the file catalog, when you store a 
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).

2. Recall the desired list file: 

a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.
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Basic Operation
Viewing, Saving, and Recalling Data
Moving or Copying a Stored Instrument State

Figure 3-6 Instrument State File Catalog

To change a comment on a saved instrument state:

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].

4. Press Re-SAVE Seq[n] Reg[nn]. 

This overwrites previously saved instrument state settings with the new comment. 

Sequence Register

A user-created state file’s default 
name is its memory location.

To move the file, rename it to the 
desired sequence and register.

You can not give a file the same 
name as an existing file.

Caution
If you rename a state file to 
something other than a valid 
sequence/register name, the file 
does not appear in either the 
Save or Recall menu.

User Preset Information
If you rename this file, the signal generator no longer recognizes it as user preset 
information.

Defining a User Preset
Set up the instrument as desired, then press User > Save User Preset.

Creating More than One User Preset
Set up several preset conditions under different names; give the one you wish to use the name 
USRPRST. To use a different file, rename the current USRPRST, then give the desired file the 
name USRPRST.

Note
To define a user preset, set up the instrument as desired and press User > Save User Preset.
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Basic Operation
Viewing, Saving, and Recalling Data
Selecting Internal or External Media

In the External Media menu (shown below), select the desired storage type.

Using External Media

When you connect storage media to the front panel USB connector, the signal generator displays the 
menu shown in the figure below, and the message External USB Storage attached. When you 
disconnect the USB media, the message External USB Storage detached displays. When you open 
the External Media menu without USB media connected, the signal generator displays the message 
External Media Not Detected.

The signal generator does not format external media, create directories, or change file permissions. 
Use a computer to perform these operations.

Non-Volatile Storage
Int = Internal

Ext = External; if a memory stick is not connected, 
non-volatile storage is not available.

Auto = External if present, otherwise internal is used.

File > More > 
External Media File Manager >

File Type
List
State
Waveform
User Flatness
User Preset
License

Extension
.list
.state
.waveform
.uflat
.uprst
.lic

Save From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Agilent purchase

Pressing Select with file highlighted...
loads list and starts sweep
load instrument state
loads and plays waveform
loads and applies user flatness
loads and executes user preset
installs purchased license

Requires 
confirmation

File Length (including extension)

Internal Media: 25 characters

External Media: 39 characters

To navigate the directory, 
use the Select hardkey and 
the Up Directory softkey.

Deletions, backups, and 
restores require confirmation.

To set the directory that the signal generator will use on the external media:
1. Navigate to the directory. It will display in the path.

2. Press this softkey.
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Reading Error Messages
If an error condition occurs, the signal generator reports it to both the front panel display error 
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed 
separately; for information on the SCPI error queue, refer to the Programming Guide.

Error Message Format

In the front panel display 
error queue, error 
messages display on an 
enumerated (“1 of N”) 
basis.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Drops the oldest error as each new error comes in.

Viewing Entries Press: Error > View Next (or Previous) Error Page

Clearing the Queue Press: Error > Clear Error Queue(s)

Unresolved Errorsa

aErrors that must be resolved. For example, unlock.

Re- reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue:
No Error Message(s) in Queue 0 of 0

Error Number Error Message
Error Description

(May be truncated on the display)

−222 Data out of range; value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal 
source frequency that is beyond the specific limits 

Explanation is provided in the Error Message file (see page 148)
(This is not displayed on the instrument)

Message number and longer description

new indicates a message generated 
since messages were last viewed.

The annunciator indicates an unviewed message.

Error messages appear in the lower-left corner 
of the display as they occur.
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4 Optimizing Performance

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 23 and familiarize yourself with the information in that 
chapter.

• Using User Flatness Correction on page 44

• Using Unleveled Operating Modes on page 47

• Using an Output Offset, Reference, or Multiplier on page 49
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Optimizing Performance
Using User Flatness Correction
Using User Flatness Correction
User flatness correction enables you to adjust the RF output amplitude for up to 1601 sequential 
linearly or arbitrarily spaced frequency points to compensate for external losses in cables, switches, 
or other devices. 

You can create and save individual user flatness correction tables, which enables you to recall 
different correction arrays for various test setups or frequency ranges (see page 46).

Figure 4-1 User Flatness Correction Softkeys

Basic Procedure
1. Create a user flatness array: Enter the user flatness correction values.

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.

Confirm

For details on each key, use key help
as described on see page 23.
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Optimizing Performance
Using User Flatness Correction
Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:

a. Preset the signal generator.

b. Open the User Flatness table editor and preset the cal array:
Press Amptd > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.

c. In the Step Array menu, enter the desired flatness- corrected frequencies: 

d. Populate the user flatness correction array with the step array configured in the previous 
step: 

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

e. Set the output amplitude to 0 dBm.

f. Turn on the RF output.

2. Connect the power meter to the RF output and manually enter the correction values:

a. Open the User Flatness table editor and highlight the frequency value in row 1: 
Press More > User Flatness > Configure Cal Array.

The RF output changes to the frequency value of the table row containing the cursor. 

b. Note the value measured by the power meter.

c. Subtract the measured value from 0 dBm

d. Highlight the correction value in row 1.

e. Press Select > the difference calculated in step c > Enter.

The signal generator adjusts the output amplitude based on the correction value entered.

f. If the power meter does not read 0 dBm, adjust the value in step e until it does.

g. Highlight the frequency value in the next row. 

h. Repeat steps b through g for this and the remaining rows.

The user flatness correction array title displays User Flatness:, without a name, indicating that 
the current user flatness correction array data has not been saved to the file catalog.

Press Configure Step Array > 

Freq Start > 500 > MHz >

Freq Stop > 1 > GHz >

# of Points > 10 > Enter
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Optimizing Performance
Using User Flatness Correction
Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a UFLT file. Any user 
flatness correction files saved to the catalog can be recalled, loaded into the correction array, and 
applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

• Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the 
array is applied to the RF output.

Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If 
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction 
Values on page 45.

1. Preset the signal generator.

2. Recall the desired User Flatness Correction file:

a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.

b. Press More > Load/Store.

c. Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file: 
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On.
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Optimizing Performance
Using Unleveled Operating Modes
Using Unleveled Operating Modes

Figure 4-2 Power Search and ALC Off Softkeys

ALC Off Mode

Turning ALC off deactivates the signal generator’s automatic leveling circuitry, enabling you to 
measure the output at a specific point in a test setup and adjust as required for the desired power 
level at that point. Turning ALC off is useful when the modulation consists of very narrow pulses 
that are below the pulse width specification of the ALC, or when the modulation consists of slow 
amplitude variations that the automatic leveling would remove.

1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Connect the power meter to the point at which you want a specific power level.

5. Turn the RF output on.

6. Deactivate the signal generator’s automatic leveling control: Press AMPTD > ALC Off On to 
highlight Off.

7. Adjust the signal generator’s amplitude until the power meter measures the desired level.

Available only when
ALC = Off

Available only when
Power Search = Span

Available only when 
Power Search = Span, 
and 
Span Type = User

Auto: The calibration routine executes whenever 
output frequency or amplitude changes.

Span: Pressing Do Power Search executes the 
power search calibration routine once over a 
selected frequency range.

The corrections are stored and used whenever you 
tune the signal generator to within the calibrated 
frequency range.

For details on each key, use key help
as described on see page 23.
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Using Unleveled Operating Modes
Power Search Mode

Refer to Figure 4- 2 on page 47. Power search executes a routine that temporarily activates the ALC, 
calibrates the power of the current RF output, and then disconnects the ALC circuitry. 

NOTE For the power search routine to execute, RF must be on and ALC must be off.

Example: Automatic Power Search
1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic leveling control: 

Press AMPTD > ALC Off On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument change 
that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes. 
The Do Power Search feature enables you to execute a power search to compensate for other changes, 
such as temperature drift or a change in the external input.
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Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) from the entered value.

RF Output = entered value − offset value

Displayed Value = output frequency + offset value

To set an offset:

• Frequency: Press Freq > Freq Offset > offset value > frequency unit.

• Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Examples

When using the signal generator as a local oscillator (LO), you can use the offset to display the 
frequency of interest, as illustrated below:

Parameter
Example

#1
Example

#2
Example

#3 Comments

Entered (and displayed) Value: 300 MHz 300 MHz 2 GHz The entered value must be positive.

Offset: 50 MHz −50 MHz −1 GHz An offset value can be positive or negative.

Output Frequency: 250 MHz 350 MHz 3 GHz The signal generator alerts you if the 
output frequency or amplitude is out of range.

Indicates that an offset is on

IF AmplifierRF Amplifier Mixer Filter

Signal Generator
(local oscillator)

Output Frequency = 1000 MHz

IF = 321 MHz

Antenna tuned to 1321 MHz

Selected Offset

321 MHz

−679 MHz

SIgnal Generator Display

1321 MHz  (Antenna Frequency)

321  MHz (IF Output)

IF Output
321 MHz
Agilent N5181A/82A MXG Signal Generators User’s Guide 49



Optimizing Performance
Using an Output Offset, Reference, or Multiplier
Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) by the entered value from a chosen reference value. 

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set 
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.” 
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.

Examples

To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the 
steps above.

Parameter Example
#1

Example
#2

Example
#3

Comments

Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.

Entered (and displayed) Value: 2 MHz −2 MHz −1 GHz The entered value can be positive or negative.

Output Frequency: 52 MHz 48 MHz 1 GHz
The signal generator alerts you if the output frequency or 
amplitude is out of range.

Indicates that a reference is on
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Optimizing Performance
Using an Output Offset, Reference, or Multiplier
Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple 
(positive or negative) of the output value. 

Displayed Value = multiplier value × output frequency

Output Frequency = displayed value ÷ multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency.
The display equals the output frequency times the multiplier value.

Examples

When using the signal generator as the input to a system, you can set the frequency multiplier so 
that the signal generator displays the output of the system, as illustrated below using a doubler:

Parameter
Example

#1
Example

#2
Example

#3 Comments

Frequency Multiplier: 3 −3 4 A multiplier value can be positive or negative.

Entered (and displayed) Value: 600 MHz −600 MHz 8 GHz

Output Frequency: 200 MHz 200 MHz 2 GHz The signal generator alerts you if the output frequency is 
out of range.

Indicates that a frequency multiplier is on

Signal Generator Doubler

Output = 4 GHz
X2

Input = 2 GHz Selected
Multiplier

2

Signal Generator
Output

2 GHz

Entered/Displayed
Frequency

4 GHz
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When measuring mixers, the frequency multiplier and frequency offset are often used together. In the 
upconverter example below, the multiplier is set to −1 and the offset is set to 3 GHz so that the 
signal generator displays fRF.

Mixer

Signal Generator
(local oscillator)

fLO = 800 − 600 MHz

fIF = 3000 MHz

Selected
Multiplier

−1

−1

Signal Generator
Output (fLO)

800 MHz

600 MHz

fRF = 2200 - 2400 MHz

Selected
Offset

3000 MHz

3000 MHz

Entered/Displayed
Frequency
(fRF)

2200 MHz

2400 MHz
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5 Using Analog Modulation (Option UNT Only)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 23 and familiarize yourself with the information in that 
chapter.

• The Basic Procedure on page 54

• Using an External Modulation Source on page 55

• Removing a DC Offset on page 55

Figure 5-1 Analog Modulation Softkeys

See 
page 55

See 
page 55

See 
page 55

For details on each key, use key help
as described on see page 23.
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Using Analog Modulation (Option UNT Only)
The Basic Procedure
The Basic Procedure
1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

5. Turn on the modulation:

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 143.

See also “Modulating the Carrier Signal” on page 34.

AM FM  ΦM

a. Press AM

b. Set the AM type (linear or exponential): 
AM Type to highlight desired type

c. Set the depth: 
AM Depth > value > %

d. Set the rate: 
AM Rate > value > frequency unit

a. Press FM/ΦM

b. Set the deviation: 
FM Dev > value > frequency unit

c. Set the rate: 
FM Rate > value > frequency unit

a. Press FM/ΦM > FM ΦM

b. Set the BW (normal or high):
FM ΦM to highlight desired type

c. Set the deviation: 
ΦM Dev > value > pi rad

d. Set the rate: 
ΦM Rate > value > frequency unit

AM FM  ΦM

AM Off On softkey to On FM Off On softkey to On  ΦM Off On softkey to On
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Using Analog Modulation (Option UNT Only)
Using an External Modulation Source
Using an External Modulation Source

Removing a DC Offset

To eliminate an offset in an externally applied FM or ΦM signal, perform a DCFM or DCΦM 
Calibration.

NOTE You can perform this calibration for internally generated signals, but DC offset is not usually 
a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.

2. Press FM/ΦM > More > DCFM/DCΦM Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal, 
and the applied DC level becomes the new zero reference point. When you disconnect the DC signal, 
perform the calibration again to reset the carrier to the correct zero reference.

AM input

Rear panel inputs are
described on page 9

FM or ΦM input

Default

Select to use external modulation

Currently selected modulation.
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Using Analog Modulation (Option UNT Only)
Using an External Modulation Source
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6 Using Pulse Modulation (Option UNU)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 23 and familiarize yourself with the information in that 
chapter.

• Pulse Characteristics on page 59

• The Basic Procedure on page 61

• Example on page 61
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Using Pulse Modulation (Option UNU)
Figure 6-1 Pulse Softkeys

See page 61

See page 61

Latency from the external 
pulse input to the pulse 
sync output ≈ 50−60 ns.

Width Period
50 ns > 50 ns
20 ns ≤ 50 ns

For details on each key, use key help
as described on page 23.

Determines how the signal generator 
responds to an external pulse signal.
Normal = high state.
Invert = low state.

Low = settled

TTL signal

See also, page 9 
and page 10

Select the signal that you want 
routed to each output connector.
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Using Pulse Modulation (Option UNU)
Pulse Characteristics
Pulse Characteristics

NOTE When using very narrow pulses that are below the signal generator’s ALC pulse width 
specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn 
ALC off (see page 47).

Pulse Source Type Perioda

aAll delays, widths, and periods have a resolution of 10 ns.

Width & Delaya Uses Trigger Eventb,

bA signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.

Square Internal free run pulse train with 
50% duty cycle.

Determined by 
user defined rate.

 

Free Run
(default) Internal free run pulse train User Defined User Defined 

Triggered Internal pulse train  User Defined ✓

Adjustable
Doublet

Two internal pulse trains for each 
trigger event. 

User Defined:

First pulse is relative to the 
rising edge of trigger signal.

Second pulse is relative to the 
rising edge of first pulse.

See Figure 6- 2 on page 60

✓

Trigger
Doublet

Two internal pulse trains for each 
trigger event.



The first pulse follows the 
trigger signal.

Second pulse is user defined.

See Figure 6- 3 on page 60

✓

Gated Internal gated pulse train  User Defined ✓

External External pulse signal at the rear 
panel Pulse connector

  

External pulse input

Rear panel inputs are described on page 9
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Using Pulse Modulation (Option UNU)
Pulse Characteristics
Figure 6-2 Adjustable Doublet

Figure 6-3 Trigger Doublet

The delay of the first pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External
Trigger

The delay of the second pulse is measured from 
the leading edge of the first pulse.

Delay Width

The delay of the second pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External
Trigger

The first pulse follows the 
external trigger signal.
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Using Pulse Modulation (Option UNU)
The Basic Procedure
The Basic Procedure
1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

5. Turn on the modulation: Pulse Off On softkey to On.

The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 34.

Example
The following example uses the factory preset pulse source and delay.

1. Preset the signal generator.

2. Set the frequency to 2 GHz.

3. Set the amplitude to 0 dBm.

4. Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

5. Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

6. Turn on both the pulse modulation and the RF output. 

The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 143. 

Square Free Run (default) Triggered Adjustable Doublet Trigger Doublet Gated External

Pulse Rate      

 Pulse Period    Pulse Period 

 Pulse Delay Pulse Delay Pulse Delay Pulse Delay  

 Pulse Width Pulse Width Pulse Width Pulse Width Pulse Width 

   Pulse 2 Delay   

   Pulse 2 Width   

Output: A 2 GHz, 0 dBm carrier modulated by a 24 µs pulse that has a period of 100 µs.
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Example
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7 Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 
3, “Basic Operation,” on page 23 and familiarize yourself with the information in that chapter.

See Also: “Adding Real- Time Noise to a Dual ARB Waveform” on page 130
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Basic Digital Operation—No BBG Option Installed
I/Q Modulation
I/Q Modulation
The following factors contribute to the error vector magnitude:

• Differences in amplitude, phase, and delay between the I and Q channels

• DC offsets

The I/Q menu provides adjustments to compensate for some of the differences in the I and Q signals 
or to add impairments.

See also, “Modulating the Carrier Signal” on page 34.

Figure 7-1 I/Q Display and Softkeys

The following table shows common uses for the adjustments.

Table 7-1 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier Feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay

This panel displays the external 
I/Q signal routing.

This panel displays the current status and settings 
of the I/Q adjustments. Grey indicates I/Q 
adjustments are off.

For details on each key, use key help
as described on page 23.

Offsets the phase of the Q signal relative to the phase of the 
I signal. The quadrature adjustment key is calibrated in units 
of degrees. This adjustment is not calibrated. 

Sets the dc offset
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Basic Digital Operation—No BBG Option Installed
I/Q Modulation
Configuring the Front Panel Inputs

The Agilent MXG accepts externally supplied analog I and Q signals through the front- panel I Input 
and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors.

a. Connect an analog I signal to the signal generator’s front- panel I Input.

b. Connect an analog Q signal to the signal generator’s front- panel Q Input.

2. Turn on the I/Q modulator: Press I/Q Off On to On.

3. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 64) as needed.
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Basic Digital Operation—No BBG Option Installed
I/Q Modulation
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8 Basic Digital Operation (Option 651/652/654)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 
3, “Basic Operation,” on page 23 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 651, 
652, or 654.

• Waveform File Basics on page 68

• Storing, Loading, and Playing a Waveform Segment on page 70

• Setting the Baseband Frequency Offset on page 72

• Waveform Sequences on page 74

• Saving a Waveform’s Settings & Parameters on page 78

• Using Waveform Markers on page 82

• Triggering a Waveform on page 98

• Clipping a Waveform on page 105

• Scaling a Waveform on page 114

• I/Q Modulation on page 121

See Also: “Adding Real- Time Noise to a Dual ARB Waveform” on page 130
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Basic Digital Operation (Option 651/652/654)
Waveform File Basics
Waveform File Basics
There are two types of waveform files: 

• A segment is a waveform file that you download to the signal generator.

For information on creating and downloading waveform files, refer to the Programming Guide. 

• A sequence is a file you create in the signal generator that contains pointers to one or more 
waveform files (segments, other sequences, or both). 

For information on creating sequences, see page 74.

Signal Generator Memory

The signal generator has two types of memory:

• Volatile memory, baseband generator (BBG) media, where waveform files are played from or 
edited.

• Non- volatile memory, either internal (int) or external (USB) media, where waveform files are 
stored.

Dual ARB Player

The dual ARB waveform player enables you to play, rename, delete, store, and load waveform files in 
addition to building waveform sequences. The dual ARB waveform player also provides markers 
(page 82), triggering (page 98), clipping (page 105), and scaling (page 114) capabilities.

Most procedures in this section start from the Dual ARB menu, shown below. 
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Basic Digital Operation (Option 651/652/654)
Waveform File Basics
Figure 8-1 Dual ARB Softkeys

page 130

page 10

page 114

page 10

page 70

If you set the ARB sample clock when the dual ARB 
is off, the new setting is applied when the dual ARB 
player is turned on; this setting survives toggling 
the Dual ARB player off and on.

page 82

page 78

page 98

For details on each key, use key help
as described on page 23.

Note: This is the
first of three 
Arb menus.

Note: This is second of 
three Arb menus.

Note: This is third of 
three Arb menus.

page 74

page 72

page 114
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Basic Digital Operation (Option 651/652/654)
Storing, Loading, and Playing a Waveform Segment
Storing, Loading, and Playing a Waveform Segment
See also, Viewing, Saving, and Recalling Data on page 35.

Figure 8-2 Waveform Segment Softkeys

Storing/Renaming a Waveform Segment to Non-Volatile Memory (Internal or External Media)

Use the following steps to store a copy of a file in BBG memory to the currently selected media 
(page 41). If you have not downloaded a waveform segment, either refer to the Programming Guide, 
or use one of the factory- supplied segments. 

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. In the Segment On BBG Media column, highlight any waveform segment.

3. Press Load Store to highlight Store.

4. Highlight the waveform segment you want to store.

5. Optionally rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want to 
overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.
b. Enter a name for the waveform segment.
c. Press Enter > More.
d. Highlight the waveform segment that was renamed.

6. Press Store Segment to currently selected Media.

See page 82

For details on each key, use key help
as described on page 23.

Note: When a sequence is highlighted, this key name 
changes to Show Waveform Sequence Contents.

Use the arrow keys or knob to 
highlight a letter or character
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Basic Digital Operation (Option 651/652/654)
Storing, Loading, and Playing a Waveform Segment
7. Repeat Step 4 through Step 6 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press 
Store All to currently selected Media.

Loading a Waveform Segment into BBG Media (Volatile Memory)

Waveform segments must reside in BBG media before they can be played, edited, or included in a 
sequence. Cycling power or rebooting the signal generator deletes the files in BBG media.

NOTE Each time the instrument powers up, two factory- supplied segments are automatically 
created in BBG media: RAMP_TEST_WFM and SINE_TEST_WFM.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Load.

3. Highlight the waveform segment you want to load.

4. If there is already a copy of this segment in the currently selected media and you do not want to 
overwrite it, rename the waveform segment before you load it (refer to the previous procedure).

5. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press 
Load All From currently selected Media. 

Playing a Waveform Segment
1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.

3. Press Select Waveform > ARB Off On to On.

This plays the selected waveform segment. During the waveform segment generation, both the I/Q 
and ARB annunciators turn on, and the waveform modulates the RF carrier. 

4. Configure the RF Output: 

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform segment is now available at the signal generator’s RF OUTPUT connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Setting the Baseband Frequency Offset
Setting the Baseband Frequency Offset

Figure 8-3 Baseband Frequency Offset Softkey

The baseband frequency offset enables you to shift the baseband frequency up to ±50 MHz within the 
BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband generator option. 
Common uses for the offset feature include:

• offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)

• sum the baseband signal with external I and Q inputs to create a multicarrier signal

• use the signal generator’s I/Q signal as an IF

NOTE Changing the baseband frequency offset may cause a DAC over range condition that 
generates error 628, Baseband Generator DAC over range. When this occurs, reduce the 
waveform runtime scaling value (page 114).

The baseband frequency offset value is one of the file header parameters (page 78), which means you 
can store this value with the waveform. When you select a waveform with a stored frequency offset 
value, the signal generator changes the current value to match the stored file header value. If there 
is no stored baseband offset frequency value for the current waveform, the signal generator uses the 
last set frequency offset value. 

You can also use the Save function (page 35) to store this value as part of the signal generator setup. 
When you Recall a setup stored with the Save function, the baseband frequency offset value becomes 
the current instrument setting value, disregarding the stored file header value.

See page 130

See page 114

Frequency offset setting.

The settings in this menu 
can be stored to the file 
header, see page 78.

For details on each key, use key help
as described on page 23.
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Basic Digital Operation (Option 651/652/654)
Setting the Baseband Frequency Offset
Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the 
factory supplied waveform, SINE_TEST_WFM. To view the output for this example, connect the RF 
OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE_TEST_WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press ARB Setup > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the 
following figures.

Modulated carrier with 0 Hz 
baseband frequency offset

Modulated carrier with 20 MHz 
baseband frequency offset Modulated RF signal

LO/carrier feedthrough

Spectrum analyzer set to a span of 100 MHz
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Basic Digital Operation (Option 651/652/654)
Waveform Sequences
Waveform Sequences

Figure 8-4 Waveform Sequence Softkeys

A waveform sequence is a file that contains pointers to one or more waveform segments or other 
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or 
other sequences, or both thereby eliminating the need to stop waveform playback just to select 
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the 
sequence; you must also store the individual segments or they are lost when you turn off or reboot 
the signal generator. If the segments are located in internal/external media, you must load them into 
BBG media prior to selecting a waveform sequence. If you attempt to play a sequence without the 
segments loaded into BBG media, the signal generator reports: ERROR: 629, File format invalid. 
If this happens and the segments are not stored in internal/external media, you must recreate the 
segments using the same file names that the sequence points to before you can play the sequence. 

For details on each key, use key help
as described on page 23.

Mode > 
Dual ARB >

Sequence name

Sequence contents

see page 95

To display this softkey, highlight a waveform sequence
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Basic Digital Operation (Option 651/652/654)
Waveform Sequences
Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences 
(nested sequences). The signal generator lets you set the number of times the segments and nested 
sequences repeat during play back. But there is a difference between repeating a segment versus 
repeating a nested sequence. Each segment can repeat up to 65,535 times, but no matter how many 
times a segment repeats, it counts as a single segment. However each repetition of a nested sequence 
counts as additional segments.

The maximum number of times that a nested sequence can repeat is based on the number of 
segments in the nested sequence and the remaining number of allowed segments (1,024). For 
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the 
nested sequence is limited to 250 repetitions:

24 + (4 × 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can 
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of 
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on loading 
waveform segments into BBG media, see page 71. 

1. Select the first segment:

a. Press Mode > Dual ARB > More  > More > Waveform Sequences > Build New Waveform Sequence > 
Insert Waveform.

b. Highlight the desired waveform segment and press Insert.

2. Select the second segment:

a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting

3. Name and store the waveform sequence to the Seq file catalog:

a. Press More > Name and Store.

b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 76 and “Setting Marker Points in a Waveform 
Segment” on page 89.

Waveform
Sequence

Sequence A

Sequence B

Sequence A
repeated 4x

Segment 1

Segment 2

Segment 3

2 segments

9 segments

11 segments

8 Segments
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Basic Digital Operation (Option 651/652/654)
Waveform Sequences
Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence, through the Waveform Sequences 
softkey or the Select Waveform softkey:

Waveform Sequences Softkey
1. Press Mode > Dual ARB > More  > More > Waveform Sequences.
2. Highlight the desired sequence.
3. Press Show Waveform Sequence Contents.

Waveform Select Softkey
1. Press Mode > Dual ARB > Select Waveform.
2. In the Sequence On column, highlight the desired waveform sequence.
3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

• change the number of times each segment or nested sequence plays
• delete segments or nested sequences from the sequence
• add segments or nested sequences to the sequence
• toggle markers on and off (described on page 95)
• save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.
Sequences save to the Seq file catalog.

CAUTION If you edit and resave a segment used in a sequence, the sequence does not 
automatically update the RMS value in its header. You must select and update the 
sequence header information (page 78).

Use the following steps to edit a sequence that has two different segments so that the first segment 
repeats 100 times and the second segment repeats 200 times, then save the changes.

Assumption: A waveform sequence that has two different segments has been created and stored (see 
previous example on page 75).

1. Select the sequence: 
Press Mode > Dual ARB > More > More > Waveform Sequences > highlight the desired sequence > 
Edit Selected Waveform Sequence.

2. Change the first segment so that it repeats 100 times: 
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry. 

3. Change the repetition for the selected entry to 200: 
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps: 
Press More > Name and Store > Enter.

To save the changes as a new sequence: 
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Basic Digital Operation (Option 651/652/654)
Waveform Sequences
a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence. 

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 75.

NOTE To play a waveform segment individually or as part of a waveform sequence, the segment 
must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media (Volatile 
Memory)” on page 71.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RMP200) from the Sequence On 
column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform: 
SEQ:SINE100+RMP200).

2. Generate the waveform: 
Press ARB Off On to On. 

This plays the selected waveform sequence. During the waveform sequence generation, both the 
I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier. 

3. Configure the RF output: 

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Saving a Waveform’s Settings & Parameters
Saving a Waveform’s Settings & Parameters
This section describes how to edit and save a file header. When you download only a waveform file 
(I/Q data, which the signal generator treats as a waveform segment), the signal generator 
automatically generates a file header and a marker file with the same name as the waveform file. 
Initially the file header has no signal generator settings saved to it, and the marker file consists of all 
zeros. For a given waveform, you can save signal generator settings and parameters in its file header 
and marker settings in its marker file (page 82); when you load a stored waveform file into BBG 
media, the file header and marker file settings automatically apply to the signal generator so that the 
dual ARB player sets up the same way each time the waveform file plays. 

Figure 8-5 Header Utilities Softkeys

When you create a waveform sequence (as described on page 75), the signal generator automatically 
creates a waveform sequence header that takes priority over the individual waveform segment 
headers. During a waveform sequence playback, the segment headers are ignored, except to verify 
that all required options are installed. Storing a waveform sequence also stores its file header. 

Some of the current signal generator settings shown in the file header, appear as part of the softkey 
labels and others appear in the dual ARB summary display, shown in the following example.

See page 79

Mode > Dual ARB > 
More > More > 
Header Utilities >

For details on each key, 
use key help
as described on page 23.

ARB summary, file
header settings

Softkey labels,
file header
settings

Softkey label,
file header
setting

All settings in this menu
can be stored to the file
header.
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Basic Digital Operation (Option 651/652/654)
Saving a Waveform’s Settings & Parameters
Viewing and Modifying Header Information 

The following example uses the factory- supplied waveform file RAMP_TEST_WFM.

1. From BBG media, select the waveform RAMP_TEST_WFM: 

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP_TEST_WFM.

c. Press Select Waveform.

2. Open the Header Utilities menu:

Press More > More > Header Utilities

The Figure 8- 6 shows the default file header for the factory- supplied waveform RAMP_TEST_WFM. 
The Header Field column lists the file header parameters; use the Page Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified. 
Unspecified means that there is no setting saved for that particular parameter.

The Current Inst. Settings column shows the current signal generator settings. In this 
example, these are the settings that you will save to the file header. 

NOTE If a setting is unspecified in the file header, the signal generator uses its current value for 
that setting when you select and play the waveform.

Figure 8-6 Example File Header

3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now display 
the same values; the Saved Header Settings column lists the settings saved in the file header.

The name of the waveform file.

The description can be up to 
32-characters.

Mode > Dual ARB > More > More > Header Utilities >

Default header settings Current signal generator settings

Resets the saved header settings 
entries to default settings
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Basic Digital Operation (Option 651/652/654)
Saving a Waveform’s Settings & Parameters
4. Edit and Update Settings

a. Return to the ARB Setup menu: 
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the file 
header. Figure 8- 1 on page 69 shows the ARB Setup softkeys used in the following steps.

b. Set the ARB sample clock to 5 MHz: 
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%:
Press Waveform Runtime Scaling > 60 > %.

d. Return to the Header Utilities menu: 
Press Return > More > More > Header Utilities.

As shown in the following figure, the Current Inst. Settings column now reflects the 
changes to the current signal generator setup, but the saved header values have not changed.

e. Save the current settings to the file header: 
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved Header 
Settings column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the 
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings column 
and are used instead of the saved header settings. To reapply the saved header settings, reselect the 
waveform for playback.

Values differ between 
the two columns
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Saving a Waveform’s Settings & Parameters
Viewing & Editing a Header without Selecting the Waveform

As described on page 79, you can view and edit a waveform’s header information after you select the 
waveform; you can also edit waveform header information without selecting a waveform, or for 
another waveform than the one that is currently selected.

1. Access the file header utilities menu:
Press Mode > Dual ARB > More > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was last 
selected. The following figure shows an example of the factory- supplied waveforms in BBG media. 

2. If the desired catalog is not displayed, select it. 

3. Highlight the desired waveform file and press Select Header.

The signal generator displays the file header for the selected waveform file. 

4. To edit the header, press More, and proceed as described in Step 4 on page 80 (Viewing and 
Modifying Header Information section).

Active waveform catalog

Waveform sequences stored in 
internal or external media

Waveforms segments stored in BBG media

Active media

Type:
WFM1 = Volatile Segment
NVWFM = Non-Volatile Segment
SEQ = Sequence

Active catalog

For details on each key, use key help
as described on page 23.

Waveform segments stored in 
internal or external media
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Using Waveform Markers
Using Waveform Markers
The signal generator provides four waveform markers to mark specific points on a waveform segment. 
When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear 
panel event output that corresponds to the marker number.

• Event 1 is available at both the EVENT 1 BNC connector (see page 12), and a pin on the 
AUXILIARY I/O connector (see page 13).

• Events 2 through 4 are available at pins on the AUXILIARY I/O connector (see page 13).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a 
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer 
to “Using Waveform Markers” on page 82 for details.

When you download a waveform file that does not have a marker file associated with it, the signal 
generator creates a marker file without any marker points. Factory- supplied segments have a marker 
point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player. 
These procedures also discuss two types of points: a marker point and a sample point. A marker 
point is a point at which a given marker is set on a waveform; you can set one or more marker 
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:

“Clearing Marker Points from a Waveform Segment” on page 88

“Setting Marker Points in a Waveform Segment” on page 89

“Controlling Markers in a Waveform Sequence” on page 95

This section also provides the following information:

• “Waveform Marker Concepts” on page 83

• “Accessing Marker Utilities” on page 87

• “Viewing Waveform Segment Markers” on page 88

• “Viewing a Marker Pulse” on page 92

• “Using the RF Blanking Marker Function” on page 93

• “Setting Marker Polarity” on page 94
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Using Waveform Markers
Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers to mark specific points on a 
waveform segment. You can set each marker’s polarity and marker points (on a single sample point 
or over a range of sample points). Each marker can also perform ALC hold, or RF Blanking and ALC 
hold.

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator. 
However some settings such as amplitude, filters, and so forth within the RF output path can create 
delays between the marker EVENT output signal and the modulated RF output. When using the 
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency, 
and if needed, reset the marker point positions, include delay (page 125), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker 
file associated with it causes the signal generator to automatically create a marker file, but does not 
place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media 
(see “Loading a Waveform Segment into BBG Media (Volatile Memory)” on page 71).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, 
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker 
polarities or routing (RF Blanking and ALC Hold) and save the information to the file header 
(page 78). 

NOTE When you use a waveform that does not have marker routings and polarity settings stored in 
the file header, and the previously played waveform used RF Blanking, ensure that you set 
RF Blanking to None. Failure to do so can result in a no RF output condition or a distorted 

Marker 
File
Bit N

Marker
Polarity

Marker N 
RF Blank Off On

Marker N
Blanks RF 

when Marker is 
Low

EVENT N

Negative

Positive

Set Marker
On Off

Marker N 
ALC Hold Off On

Marker N
Holds ALC 

when Marker is 
Low

When the signal generator encounters an enabled marker (described on page 95), an 
auxiliary output signal is generated and routed to the rear panel. 

Event 1 is available at the EVENT 1 BNC connector (see page 12), and at a pin on the 
AUXILIARY I/O connector (see page 13).

Events 2 through 4 are available at pins on the AUXILIARY I/O connector (see page 13).

RF Blank Only: includes ALC Hold
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waveform.

ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before 
or after you set marker points (page 89), setting a marker function before setting marker points may 
cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods, 
burst ramps, or when the increased dynamic range encountered with RF blanking (page 93) is not 
desired. 

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points 
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output 
signal (the carrier plus any modulating signal) when the marker signal goes high:

NOTE Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer 
than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 48.

CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create a spike 
in the RF output, potentially damaging a DUT or connected instrument. To prevent this 
condition, ensure that you set markers to let the ALC sample over an amplitude that 
accounts for the higher power levels encountered within the signal.

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

Positive Polarity
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Close-up of averaging

The ALC samples the waveform when the marker signal goes 
high, and uses the average of the sampled waveform to set the 
ALC circuitry.

Here the ALC samples during the on marker points (positive 
polarity).

Marker Marker

MarkerMarker

Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of 
highest amplitude. Note that the marker is set well before the 
waveform’s area of lowest amplitude. This takes into account any 
response difference between the marker and the waveform signal.

Pulse Unleveled

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the 
same waveform, which sets the ALC modulator circuitry for 
that level; this usually results in an unleveled condition for the 
signal generator when it encounters the high amplitude of the 
pulse.

MarkerMarker
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Sample range begins on first point of signal

Negative range set between signal and 
off time

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during 
the marker on points; the marker signal goes high during the off 
points. The ALC samples the waveform during the off marker 
points.

Marker On Marker On

Sampling both on and off time sets the modulator circuitry 
incorrectly for higher signal levels. Note the increased amplitude 
at the beginning of the pulse.

Marker
Off

Marker On
MarkerMarker

Off On
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Accessing Marker Utilities

Mode > Dual ARB > More > 

Note: This is the 
second Arb menu.

The display below shows the I and Q components of the waveform, and 
the marker points set in a factory-supplied segment.

First sample point 
shown on display

These softkeys change 
the range of waveform 
sample points shown 
on the marker display.

Each press of the 
softkey changes the 
sample range by 
approximately a factor 
of two.Marker points 

on first 
sample point

For details on each key, use key help
as described on page 23.

The settings in these menus 
can be stored to the file 
header, see page 78.
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a 
segment (this example uses the factory- supplied segment, SINE_TEST_WFM).

1. In the second Arb menu (page 87), press Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Press Display Waveform and Markers > Zoom in Max. 

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range 
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set points, view the segment (page 88) 
and remove any unwanted points. With all markers cleared, the level of the event output signal is 0V. 
To clear marker points on a segment, the segment must reside in BBG media (page 71).

Clearing All Marker Points
1. In the second Arb menu (page 87), press Set Markers.

2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).

3. Highlight the desired marker number: Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected segment:

a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of the 
waveform. The factory- supplied waveform (SINE_TEST_WFM) contains 200 samples. To clear all 
set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other 
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10−20. This 
makes it easy to see the affected marker points. The same process applies whether the existing points 
are set over a range or as a single point (page 89).‘

1. In the second Arb menu (page 87), press Set Markers, then select Marker 1.

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than or equal to the 
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this 
example, 17): 
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Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

This turns off all marker points for 
the active marker within the range 
set in Steps 2 and 3, as shown at 
right.

How to view markers is described 
on page 88.

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 88, but set both the first and 
last marker point to the value of the point you want to clear. For example, if you want to clear a 
marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 71).

When you set marker points, they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set marker points within a segment, view 
the segment (page 88) and remove any unwanted points (page 88).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 87), press Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker 1 2 3 4

4. Set the first sample point in the range (in this example, 10):

Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in 
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.

6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends 
on sample point 20, as shown in the following figure.
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How to view markers is described on page 88
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 87), press Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number:
Press Marker 1 2 3 4.

4. Press Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in Step 3.

On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 89, but set both the 
first and last marker point to the value of the point you want to set. For example, if you want to set 
a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped 
points) between each marker. You must set the spacing before you apply the marker settings; you 
cannot apply skipped points to a previously set range of points.

1. Remove any existing marker points (page 83).

2. In the second Arb menu (page 87), press Set Markers.

3. Highlight the desired waveform segment. 

4. Select the desired marker number: 
Press Marker 1 2 3 4.

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than or 
equal to the number of points in the waveform, and greater than or equal to the first marker 
point, in this example, 25):
Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on 
every other point (one sample point is 
skipped) within the marker point range, 
as shown at right.

How to view markers is described on 
page 88.

One application of the skipped point 
feature is the creation of a clock signal 
as the EVENT output.
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Viewing a Marker Pulse

When a waveform plays (page 77), you can detect a set and enabled marker’s pulse at the rear panel 
event connector/Aux I/O pin that corresponds to that marker number. This example demonstrates 
how to view a marker pulse generated by a waveform segment that has at least one marker point set 
(page 89). The process is the same for a waveform sequence.  

This example uses the factory- supplied segment, SINE_TEST_WFM in the dual ARB Player. 
Factory- supplied segments have a marker point on the first sample point for all four markers, as 
shown.

1. In the first Arb menu (page 69), press Select Waveform.

2. Highlight the SINE_TEST_WFM segment and press Select Waveform.

3. Press ARB Off On to On.

4. Connect the Agilent MXG’s rear- panel Q OUT output to the oscilloscope’s channel 1 input.

5. Connect the signal generator’s rear- panel EVENT 1 output to the oscilloscope’s channel 2 input. 

When marker 1 is present, the Agilent MXG outputs a signal through EVENT 1 as shown in the 
following example.

Marker points on
first sample point of
waveform segment

How to view markers is described on page 88

RF Output

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the second 
Arb menu) either before or after setting the marker points (page 89), setting a marker function before 
you set marker points may change the RF output. RF Blanking includes ALC hold (described on 
page 84, note Caution regarding unleveled power). The signal generator blanks the RF output when 
the marker signal goes low. This example is a continuation of the previous example, Viewing a Marker 
Pulse.

1. Using the factory- supplied segment SINE_TEST_WFM, set Marker 1 across points 1−180 (page 89).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1: 

In the second Arb menu (page 87), press Marker Routing > Pulse/RF Blank > Marker 1.

Marker Polarity = Positive
When marker polarity is positive (the default 
setting), the RF output is blanked during the off 
marker points.

200180Point 1
Marker

Segment

RF Signal

RF Signal

200180Point 1
Marker

Segment

Marker Polarity = Negative
When marker polarity is negative, the 
RF output is blanked during the on marker 
points

≈3.3V

0V

≈3.3V

0V

RF Signal

RF Signal
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In second Arb menu (page 87), press Marker Polarity.

2. For each marker, set the marker polarity as desired.

• The default marker polarity is positive.

• Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 83.

As shown on page 93:

Positive Polarity:  On marker points are high (≈3.3V). 

Negative Polarity:  On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.
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Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed 
to the rear- panel EVENT output (described in “Rear Panel Overview” on page 9) corresponding to 
that marker number. For a waveform sequence, you enable or disable markers on a 
segment- by- segment basis; this enables you to output markers for some segments in a sequence, but 
not for others. Unless you change the sequence marker settings or cycle the power, the marker setting 
for the last segment edited in the sequence applies to all segments in the next sequence that you 
build. For information on building a waveform sequence, see “Creating a Sequence” on page 75.

Figure 8-7 Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB > 
More > More > 

Note: This is the  
third Arb menu.

For details on each key, use key help
as described on page 23.

Enable/Disable markers while 
creating a waveform sequence

Edit a sequence to 
enable/disable markers
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s 
markers independently. You can enable or disable the markers either at the time of creating the 
sequence or after the sequence has been created and stored. If the sequence has already been stored, 
you must store the sequence again after making any changes. Enabling a marker that has no marker 
points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker 
Points in a Waveform Segment” on page 89. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 71).

2. From the third Arb menu, press Waveform Sequences.

3. Highlight the desired waveform sequence.

4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.

5. Toggle the markers: 

a. Highlight the first waveform segment.

b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that 
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.

6. Press Return > More > Name and Store.

7. Either rename the sequence using the text entry keys (see page 70) or just press Enter to save the 
sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory- supplied waveform segments; a 
factory- supplied segment has a marker point on the first sample for all four markers. In this 
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and 
markers 3 and 4 are enabled for the third segment.

For each segment, only the markers enabled for that segment produce a rear- panel auxiliary output 
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is 
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second 
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.

Sequence marker column

This entry shows that markers 
3 and 4 are enabled for this 
segment.
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Using the EVENT Output Signal as an Instrument Trigger

One of the uses for the EVENT 
output signal (marker signal) is to 
trigger a measurement instrument. 
You can set up the markers to start 
the measurement at the beginning 
of the waveform, at any single point 
in the waveform, or on multiple 
points in the waveform. To optimize 
the use of the EVENT signal for 
measurements, you may also need 
to adjust the sample rate. The 
location of the sample rate setting 
is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to ±4 ns on the rising and falling edge. This jitter 
can be minimized in either of two ways. 

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can 
be represented exactly on the display. 
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on. 

If the result cannot be represented exactly on the display, jitter will be present.
For example: N = 6 will result in jitter, because , which is truncated when 
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns. 
For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz 
provides a marker every 4 µs. Because 4 µs is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause 
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample 
rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the 
original waveform with a sample rate change, you will have to also recalculate the sample values. The 
following figures illustrate the marker signal jitter and its affect on the waveform.

Sample
rate 
setting

The settings in this menu 
can be stored to the file 
header, see page 78.

For details on each key, use key help as described on page 23.

125 MHz 6⁄ 20.833 MHz=

The jitter is gone with
an optimal sample rate

Waveform appears to exhibit jitter when
triggered using EVENT signal with jitter.

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal

EVENT output signal exhibits jitter
due to a non-optimal sample rate
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Triggering a Waveform

Figure 8-8 Triggering Softkeys

Triggers control data transmission by controlling when the signal generator transmits the modulating 
signal. You can configure trigger settings so that data transmission occurs once (Single mode), 
continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another, 
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is 
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To 
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages 
set to values other than zero.

There are two parts to configuring a waveform trigger:

• Type determines the behavior of the waveform when it plays (see Trigger Type on page 99).

• Source determines how the signal generator receives the trigger that starts the modulating 
waveform playing (see Trigger Source on page 100).

Mode > Dual ARB >

See page 99

See 

For details on each key, use key help
as described on page 23.
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered.

• Continuous mode repeats the waveform until you turn the signal off or select a different waveform, 
trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

• Single mode plays the waveform once.

• Segment Advance mode plays a segment in a sequence only if triggered. The trigger source controls 
segment- to- segment playing (see Example: Segment Advance Triggering on page 101). A trigger 
received during the last segment loops play to the first segment in the sequence.

• Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and 
stops playing the waveform in response to an externally applied gating signal. See Example: Gated 
Triggering on page 102.

Mode >
Dual ARB > 
Trigger Type >

Immediately triggers and plays the waveform; triggers 
received while the waveform is playing are ignored.

Plays the waveform when a trigger is received; 
subsequent triggers are ignored.

Plays the waveform when a trigger is received; subsequent 
triggers restart the waveform

The waveform stops during the inactive
state of the trigger source, and plays 
during the active state.

Ignores triggers 
received while a 
waveform is playing.

A trigger received while 
a waveform is playing 
waits until the current 
waveform completes, 
then plays the waveform 
once more.

A trigger received while 
the waveform is playing 
immediately restarts the 
waveform.

A segment in a sequence plays 
once, ignoring the repetition 
setting, after which the dual ARB 
player stops and waits for a 
trigger before advancing to the 
next segment. The next segment 
then plays to completion. 

If a trigger is received while a 
segment is playing, the segment 
plays to completion. The dual 
ARB player then advances to the 
next segment and plays that 
segment to completion.

A segment in a sequence plays continuously until the waveform receives another trigger. 

If a trigger is received while a segment is playing, the segment plays to completion. The 
dual ARB player then advances to the next segment and plays that segment continuously. 

For details on each key, use key help
as described on page 23.
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Trigger Source

External Trigger Polarity
• In Continuous, Single, and Segment Advance modes, use the Ext Polarity softkey to set the external 

trigger polarity.

• In Gated mode, the Active Low and Active High softkeys (page 99) determine the external trigger 
polarity. 

Mode >
Dual ARB > 
Trigger Source >

Patt Trig In BNC connector 
(see page 13)

Aux I/O connector (see page 13)

Neg = the signal generator 
responds during the trigger signal 
low state.

Pos = the signal generator 
responds during the trigger signal 
high state.

For details on each key, use key help
as described on page 23.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence. 
This type of triggering ignores the repetition value (page 76). For example if a segment has repetition 
value of 50 and you select Single as the segment advance triggering mode, the segment still plays 
only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 75.

1. Preset the signal generator.

2. Configure the RF output:

• Set the desired frequency.

• Set the desired amplitude.

• Turn on the RF output.

3. Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.

c. Press Select Waveform.

4. Set the triggering as follows:

• Trigger Type: continuous Segment Advance
Press Trigger Type > Segment Advance > Continuous.

• Trigger source: Trigger hardkey
Press Trigger Source > Trigger Key.

5. Generate the waveform sequence: 
Press ARB Off On until On highlights.

6. (Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the 
oscilloscope so that you can see the signal.

7. Trigger the first waveform segment to begin playing continuously: 
Press the Trigger hardkey.

8. Trigger the second segment: 
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment 
to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first 
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear- panel PATT TRIG IN 
connector, as shown in the following figure. This connection is applicable to all external triggering 
methods. The optional oscilloscope connection enables you to see the effect that the trigger signal 
has on the RF output.

2. Preset the signal generator.

3. Configure the RF output:

• Set the desired frequency.

• Set the desired amplitude.

• Turn on the RF output.

4. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On or Sequence On column, highlight a waveform.

c. Press Select Waveform.

5. Set the triggering as follows:

• Trigger type: Gated
Press Trigger Type > Gated.

• Active state: Low
Press Active Low.

• Trigger source: External
Press Trigger Source > Ext.

• Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.
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7. On the function generator, configure a TTL signal for the external gating trigger.

8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external 
triggering signal. You will see the waveform modulating the output during the gate active periods 
(low in this example).

The following figure shows an example display.
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal 
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel 
BNC connector

1. Connect the signal generator to the function generator as shown above.

2. Configure the RF output:

• Set the desired frequency.
• Set the desired amplitude.
• Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform: 
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

d. External Trigger Polarity: positive
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms
Press More > Ext Delay until On highlights
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

• Waveform: 0.1 Hz square wave
• Output Level: 3.5V to 5V. 
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Clipping a Waveform
Clipping a Waveform
Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in 
spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function 
enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its 
highest peak, thereby reducing spectral regrowth.

• How Power Peaks Develop on page 106

• How Peaks Cause Spectral Regrowth on page 108

• How Clipping Reduces Peak- to- Average Power on page 109

• Configuring Circular Clipping on page 112

• Configuring Rectangular Clipping on page 113

Figure 8-9 Clipping Softkeys

Mode > Dual ARB > More > More >

Available only when 
clipping type = |I| , |Q|

For details on each key, use key help
as described on page 23.
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Basic Digital Operation (Option 651/652/654)
Clipping a Waveform
How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop 
as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit 
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an 
unusually high power peak (positive or negative) occurs in the summed waveform. 

Because the high and low states of the bits in channel waveforms are random and generally result in 
a cancelling effect, high power peaks occur infrequently with multiple channel summing.
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Clipping a Waveform
Combining the I and Q Waveforms

When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the magnitude 

of the RF envelope is , where the squaring of I and Q always results in a positive value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q waveforms 
do not cancel each other, but combine to create an even greater peak.
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Clipping a Waveform
How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high 
peak- to- average power ratio, as illustrated in the following figure. 

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high 
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation 
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that develops 
on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see 
the following figure). Clipping provides a solution to this problem by reducing the peak- to- average 
power ratio.
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Clipping a Waveform
How Clipping Reduces Peak-to-Average Power

You can reduce peak- to- average power, and consequently spectral regrowth, by clipping the waveform. 
Clipping limits waveform power peaks by clipping the I and Q data to a selected percentage of its 
highest peak. The Signal Generator provides two methods of clipping:

• Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 8- 10, the clipping level is constant for all phases of the vector and appears 
as a circle in the vector representation.

• Rectangular clipping is independently applied the I and Q data.

 As shown in Figure 8- 11 on page 110, the clipping level is different for I and Q, and appears as 
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that reduces 
spectral regrowth but does not compromise the integrity of the signal. The two complementary 
cumulative distribution plots in Figure 8- 12 on page 111 show the reduction in peak- to- average 
power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is 
clipped). The peaks can often be clipped without substantially interfering with the rest of the 
waveform. In many cases, data that might otherwise be lost in the clipping process is retained 
because of the error correction inherent in the coded systems. If you apply excessive clipping, 
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that 
reduces spectral regrowth while retaining needed data.

Figure 8-10 Circular Clipping
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Clipping a Waveform
Figure 8-11 Rectangular Clipping
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Clipping a Waveform
Figure 8-12 Reduction of Peak-to-Average Power
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Clipping a Waveform
Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak- to- average power 
ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped equally). 
For more information about circular clipping, refer to “How Clipping Reduces Peak- to- Average Power” 
on page 109.

CAUTION Clipping is non- reversible and cumulative. Save a copy of the waveform file before you 
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > More > Waveform 

Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_CIRC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of 
the waveform’s curve (the dark line 
in the example at right).

5. Activate circular clipping: Press 
Return > Clipping > Clipping Type until 
|I+jQ| highlights.

6. Set circular clipping to 80%: 
Press Clip |I+jQ| To > 80 > %.

7. Apply 80% clipping to the I and Q 
data: Press Apply to Waveform.

8. Create the CCDF plot (see the 
example at right): Press Plot CCDF. 

9. Observe the waveform’s curve after 
clipping. 

Note the reduction in 
peak- to- average power relative to the 
previous plot.

Example waveform curve before clipping

Example waveform curve after circular clipping
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Clipping a Waveform
Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data 
independently. For more information about rectangular clipping, refer to “How Clipping Reduces 
Peak- to- Average Power” on page 109.

CAUTION Clipping is non- reversible and cumulative. Save a copy of the waveform file before you 
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > More > Waveform 

Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_REC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of 
the waveform’s curve (the dark line 
in the example at right).

5. Activate rectangular clipping: Press 
Return > Clipping > Clipping Type until 
|I|,|Q| highlights.

6. Set 80% clipping for the I data: Press 
Clip |I| To > 80 > %.

7. Set 40% clipping for the Q data: Press 
Clip |Q| To > 40 > %.

8. Apply the rectangular clipping to the waveform: Press Apply to Waveform.

9. Create the CCDF plot (see the 
example at right): Press Plot CCDF. 

10. Observe the waveform’s curve after 
clipping. 

Note the reduction in 
peak- to- average power relative to the 
previous plot.

Example waveform curve before clipping

Example waveform curve after circular clipping
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Scaling a Waveform
Scaling a Waveform
The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when 
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which 
may create a DAC over- range error condition. This chapter describes how DAC over- range errors 
occur and how you can use waveform scaling to eliminate these errors.

• How DAC Over- Range Errors Occur on page 116

• How Scaling Eliminates DAC Over- Range Errors on page 117

• Agilent MXG waveform scaling on page 118 and page 119:

— Waveform runtime scaling to scale a currently- playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a non- playing 
waveform file in BBG media
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Basic Digital Operation (Option 651/652/654)
Scaling a Waveform
Figure 8-13 Scaling Softkeys

For details on each key, use key help
as described on page 23.

Waveform Runtime Scaling, see page 118

The settings in this menu 
can be stored to the file 
header, see page 78.

Waveform Scaling, see page 119
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Basic Digital Operation (Option 651/652/654)
Scaling a Waveform
How DAC Over-Range Errors Occur

The signal generator uses an interpolator 
filter when it converts digital I and Q 
baseband waveforms to analog 
waveforms. Because the clock rate of the 
interpolator is four times that of the 
baseband clock, the interpolator 
calculates sample points between the 
incoming baseband samples and smooths 
the waveform as shown in the figure at 
the right.

The interpolation filters in the DACs 
overshoot the baseband waveform. If a 
baseband waveform has a fast- rising 
edge, the interpolator filter’s overshoot 
becomes a component of the interpolated 
baseband waveform. This response 
causes a ripple or ringing effect at the 
peak of the rising edge. If this ripple 
overshoots the upper limit of the DAC 
range, the interpolator calculates 
erroneous sample points and is unable 
to replicate the true form of the ripple 
(see the figure at the right). As a result, 
the signal generator reports a DAC 
over- range error.
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Basic Digital Operation (Option 651/652/654)
Scaling a Waveform
How Scaling Eliminates DAC Over-Range Errors

Scaling reduces the amplitude of the baseband 
waveform while maintaining its basic shape and 
characteristics, such as peak- to- average power 
ratio. If the fast- rising baseband waveform is 
scaled enough to allow an adequate margin for 
the interpolator filter overshoot, the interpolator 
filter can calculate sample points that include 
the ripple effect and eliminate the over- range 
error (see the figure at the right).

Although scaling maintains the basic shape of 
the waveform, excessive scaling can compromise 
waveform integrity. For example, if the bit 
resolution becomes too low the waveform 
becomes corrupted with quantization noise. To 
achieve maximum accuracy and optimize 
dynamic range, scale the waveform no more 
than is required to remove the DAC over- range 
error. Optimum scaling varies with waveform 
content.
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Basic Digital Operation (Option 651/652/654)
Scaling a Waveform
Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You can 
apply runtime scaling to either a segment or sequence, and set the scaling value either while the ARB 
is on or off. This type of scaling is well suited for eliminating DAC over- range errors. Runtime scaling 
adjustments are not cumulative; the scaling value is applied to the original amplitude of the 
waveform file. There are two ways to save the runtime scaling setting: by using the save function 
(page 35) and by saving the setting to the file header (page 79). Saving to the file header saves the 
value with the waveform file, saving with the Save function stores the value as the current 
instrument setting.

Use this example to learn how to scale the currently selected waveform. 

1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB Off On until On highlights.

3. Set the Waveform Runtime Scaling value: 

a. Press ARB Setup > Waveform Runtime Scaling. 

b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is no 
single value that is optimal for all waveforms. To achieve the maximum dynamic range, use 
the largest scaling value that does not result in a DAC over- range error. 

c. Press Return. 
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Scaling a Waveform
Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform data 
and only applies to waveform segments stored in BBG media. You scale the waveform either up or 
down as a percentage of the DAC full scale (100%). If you scale your waveforms using this method, 
you may also need to change the waveform runtime scaling value to accommodate this scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so that 
they conform to the desired scaling value. When you initiate scaling, the signal generator performs 
the following actions:

• locates the waveform file’s absolute peak sample value
• determines its current percentage of full scale
• calculates the ratio of the desired scale value to the determined absolute peak sample scale value
• multiplies each sample in the waveform file by this ratio

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data occurs 
almost every time you reduce or increase the scaling value, and causes quantization errors. 
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor. 
You lose data when either the signal generator rounds fractional data down or the scaling value is 
derived using the results from a power of two. This means that scaling a waveform in half (power of 
two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not 
correctable and may cause waveform distortion. It is always best to make a copy of the original file 
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses the 
factory- supplied waveform RAMP_TEST_WFM, it is the same for any waveform file.

Copy a Waveform File
1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

Peak sample

85% of full scale—Prescaling

60% of full scale–Post scaling

DAC full scale 100%

Scaled sample value = scaling ratio × prescale sample val

Scaling ratio = desired scale val / current scale val
= 60 / 85
= 0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

Original ramp waveform Scaled ramp waveform

= Samples
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Scaling a Waveform
4. Name the copy (this example uses the name MY_TEST_SCAL) and press Enter.

Apply Scaling to the Copied Waveform File

CAUTION This type of scaling is non- reversible. Any data lost in the scaling operation cannot be 
restored. Save a copy of the waveform file before scaling.

1. Open the DUAL ARB Waveform Utilities menu: 

Press Mode > Dual ARB > More > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, MY_TEST_SCAL).

3. Set and apply a scaling value (in this example 70% scaling is applied): 

Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.
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I/Q Modulation
I/Q Modulation
The following factors contribute to the error vector magnitude:

• Differences in amplitude, phase, and delay between the I and Q channels

• DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides 
adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 34.

Figure 8-14 I/Q Display and Softkeys

These selections are 
reflected in the 
I/Q Routing & 
Optimization graphic.page 125

This panel displays the current 
settings for the I/Q signal routing 
and I/Q correction optimized path.

This panel displays the current status and settings 
of the I/Q adjustments. Use the Page Up and 
Page Down keys to scroll through these 
parameters. Grey indicates an inactive (off) 
adjustment.

Used only with internally generated, 
bursted modulation formats. 
Enables/disables the RF burst modulator.

For details on each key, use key help
as described on page 23.

Each path requires different optimization values; 
when you select a path, you are selecting the 
unique optimization values required by that path. 

The signal generator applies the selected 
optimization values to both paths, which impairs 
the unselected path.

Inverts an internally generated Q signal, so that the 
I component lags the Q component by 90 degrees.

page 127
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I/Q Modulation
Using the Rear Panel I and Q Outputs

NOTE The rear- panel I and Q connectors only output a signal while using the internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated I and 
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in 
analog form. You can use these rear panel I and Q signals to:

• drive a system’s transmitter stage
• test individual analog I and Q components such as an I/Q modulator
• route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and 
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear 
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform
1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path
1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal 

generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to the 
rear panel connectors.

You can use the rear panel I and Q signals as I and Q inputs to another signal generator. The 
MXG has front panel connectors, I Input and Q Input, for this purpose.

2. Press I/Q > I/Q Correction Optimized Path > Ext I/Q Output.
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I/Q Modulation
When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized

Rear-panel I/Q path optimized
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I/Q Modulation
Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front- panel I 
Input and Q Input. You can use the external signals as the modulating source, or sum the external 
signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.

a. Connect an analog I signal to the signal generator’s front- panel I Input.

b. Connect an analog Q signal to the signal generator’s front- panel Q Input.

2. Set the signal generator to recognize the front- panel input signals: 

• To Modulate onto the Carrier

Press I/Q > I/Q Source > External.

• To Sum and Modulate onto the Carrier

Press I/Q > I/Q Source > Sum.

To select and play a waveform for the BB GEN path, see page 71.

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear- panel I and Q 
outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator: 
Press I/Q Off On to On.

4. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

Signal generator display—both paths calibrated with 
I/Q Correction Optimized Path set to Ext I/Q 
Output (see page 122).

Signal generator display—both RF paths calibrated 
with I/Q Correction Optimized Path set to RF 
Output (see page 122).
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I/Q Adjustments
I/Q Adjustments
Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

I/Q > I/Q Adjustments >

Available only when a 
waveform is playing.

Available only
with Option 1EL

Adjusts the I signal amplitude relative to the Q 
signal amplitude. Use this as an internal 
impairment, or to compensate for differences in 
signal path loss that occur due to path 
irregularities in the external I and Q output 
cabling.

Offsets the phase of the Q signal 
relative to the phase of the I signal. 
The baseband quadrature 
adjustment key is calibrated in units 
of degrees. The external input 
quadrature adjustment is not 
calibrated. 
The function provided by this key is 
not the same as the function 
provided by the I/Q Skew key.

Skew is typically used either to create impairments, or to 
reduce error vectors on large bandwidth signals.

Provides a relative time delay correction between the I and 
Q signals. The different signal paths traveled by the I and Q 
signals result in time delay differences that show up as an 
EVM error in large bandwidth modulated signals. 

Adding an equal and opposite time delay (skew) in the I/Q 
signals during baseband generation eliminates the time 
delay error, correcting for any delays in signals that are 
generated in the internal baseband generator. 

Changes the absolute phase of both the I and Q signals with 
respect to triggers and markers. 

Positive values add delay and negative values advance the 
signals. This value affects both the baseband signal 
modulated onto the RF and the external output signals (I and 
Q). This setting cannot be used with constant envelope 
modulation and it does not affect external I and Q inputs.

Offsets are typically used to either reduce carrier leakage, or to create 
an impairment that simulates carrier leakage.

Common Mode I/Q Offset
This adjusts the DC offset of both I and Q signals simultaneously.

Diff Mode I Offset
This adjusts the DC offset level of the I and I-bar output signal. I and 
I-bar cannot be adjusted independently.

Diff Mode Q Offset
This adjusts the DC offset level of the I and I-bar output signal. I and 
I-bar cannot be adjusted independently.
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I/Q Adjustments
The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any 
latency between the EVENT output signals (marker signals) and the RF output.

Table 8-1 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay

I/Q Skew EVM error
high sample rate phase 
skew or I/Q path delay

I/Q Gain Balance I/Q amplitude difference I/Q gain ratio
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I/Q Calibration
I/Q Calibration
Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected 
depends on whether the signal is internally or externally generated.

When you perform an I/Q calibration, that calibration data takes precedence over the 
factory- supplied calibration data. The calibration routines improves performance that may degrade 
over time or due to temperature changes. 

Correction Internal I and 
Q

External I and 
Q

Offset X X

Gain Balance X - -

Quadrature 
Error

X X

I/Q > I/Q Calibration >

Available only when
Calibration type = User

For details on each key, use key help
as described on page 23.

DC optimizes the I/Q performance for the current 
instrument settings, and typically completes in several 
seconds. Changing any instrument setting except for I/Q 
adjustments after performing a DC calibration voids the DC 
calibration and causes the signal generator to revert to the 
factory−supplied calibration data.

Presetting the instrument or cycling power is equivalent to 
pressing Revert to Default Cal Setting.

User provides a quicker calibration when a full calibration 
is not required. You can limit the calibration by specifying 
the calibration start and stop frequencies. 

When you limit the calibration to less than the instrument’s 
full frequency range, the factory−supplied calibration data 
is used for the rest of the range.

Information is retained through a preset or power cycle.

Full takes 5 minutes, executing measurements over the 
instrument’s entire frequency range. 

Information is retained through a preset or power cycle.

Deletes any user-generated 
calibration data and restores 
the factory−supplied 
calibration data.
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I/Q Calibration
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9 Adding Real Time Noise to a Signal (Option 403)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 23 and familiarize yourself with the information in that 
chapter.

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform 
generator, which is available only in vector signal generators with Option 403.

• “Adding Real- Time Noise to a Dual ARB Waveform” on page 130

• “Using Real Time I/Q Baseband AWGN” on page 132
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Adding Real Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform
Adding Real-Time Noise to a Dual ARB Waveform
A vector signal generator with option 403 enables you to apply additive white gaussian noise (AWGN) 
to a carrier in real time while the modulating waveform plays in the dual ARB waveform player. 

Figure 9-1 Real Time I/Q Baseband AWGN Softkeys

For the selected carrier to noise ratio, 
the bandwidth over which the noise is 
integrated.

The amount of noise power relative to 
the carrier power.

For details on each key, use key help
as described on page 23.

The state of the noise (on or off) 
is shown on the display.

The actual noise bandwidth, which is 
typically slightly wider than the carrier 
bandwidth.
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Adding Real Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform
Use the following steps to modulate a 1 GHz, –10 dBm carrier with the factory- supplied waveform 
SINE_TEST_WFM, and then apply 45 MHz bandwidth noise that has a 30 dB noise power 
carrier–to–noise ratio across a 40 MHz carrier bandwidth.

1. Preset the signal generator and set the following:

• Frequency: 1 GHz

• Amplitude: −10 dBm

• RF output: on

2. Select the factory- supplied waveform SINE_TEST_WFM:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight SINE_TEST_WFM and press Select Waveform.

3. Turn on the dual ARB player: press ARB Off On to highlight On.

4. Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.

5. Press Real-time Noise Setup and set the following:

• Carrier to Noise Ratio: 30 dB

• Carrier Bandwidth: 40 MHz

• Noise Bandwidth: 45 MHz

• Real- time Noise: on

The signal generator’s displayed power level (–10 dBm) includes the noise power.
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Using Real Time I/Q Baseband AWGN
Using Real Time I/Q Baseband AWGN

Figure 9-2 Real Time I/Q Baseband AWGN Softkeys

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, –10 dBm carrier.

1. Configure the noise:

a. Preset the signal generator.

b. Press Mode > Real Time I/Q Baseband AWGN

c. Press Bandwidth > 10 > MHz.

2. Generate the noise:

Press AWGN Off On until On highlights.

During generation, the AWGN and I/Q 
annunciators activate (as shown at 
right). AWGN is now available to 
modulate the RF carrier.

3. Configure the RF output:

• Frequency: 500 MHz

• Amplitude: −10 dBm

• RF output: on

The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.

For details on each key, use key help
as described on page 23.
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10 Working in a Secure Environment

• Understanding Memory Types on page 134

• Removing Data from Memory (Option 006 Only) on page 136

• Using the Secure Display (Option 006 Only) on page 139
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Working in a Secure Environment
Understanding Memory Types
Understanding Memory Types
The signal generator has several memory types, and each is used to store a specific type of data. 
Before removing sensitive data, you should to understand how each memory type is used. The 
following tables describe each memory type used in the base instrument, and optional baseband 
generator.

Table 10-1 Base Instrument Memory 

Memory 
Type and 
Size
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Purpose/Contents Data Input Method Location in Instrument and Remarks

Main 
Memory 
(RAM)

32 MB

Yes No firmware operating 
memory

no user data

operating system CPU board

Main 
Memory 
(Flash)

8 MB

Yes Yes factory 
calibration/configuration 
data

auser file system, which 
includes flatness 
calibration, instrument 
states, and sweep lists

firmware upgrades 
and user- saved dataa

CPU board (same chip as firmware memory, but 
managed separately)

Because this memory chip contains 8 MB of user 
data (described here) and 8 MB of firmware 
memory, a full- chip erase is not desirable. User 
data areas are selectively and completely sanitized 
when you perform the Erase and Sanitize function.

Firmware 
Memory 
(Flash)

8 MB

No Yes main firmware image factory installed or 
firmware upgrade

CPU board (same chip as main flash memory, but 
managed separately)

During normal operation, this memory cannot be 
overwritten. It is only overwritten during the 
firmware installation or upgrade process.

Because this memory chip contains 8 MB of user 
data and 8 MB of firmware memory (described 
here), a full- chip erase is not desirable. User data 
areas are selectively and completely sanitized 
when you perform the Erase and Sanitize function.

Bootrom 
Memory 
(EEPROM)

8 kB

No Yes CPU bootup parameters

no user data

factory programmed CPU board

During normal operation, this memory cannot be 
overwritten or erased. This read- only data is 
programmed at the factory.

Calibration 
Data
(Flash)

256 kB

No Yes factory 
calibration/configuration 
data backup

no user data

factory or service only RF Board

LCD 
Display 
Memory 
(RAM)

160 kB

No No display buffer operating system RF board
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Understanding Memory Types
Front 
Panel 
Memory 
(Flash)

32 kB

No No front panel keyboard 
controller firmware

no user data

operating system Front Panel board

aAnalog instruments only

Table 10-2 Baseband Generator Memory (Options 651,652, 654) 

Memory 
Type and 
Size
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Purpose/Contents Data Input Method Remarks

Waveform 
Memory 
(RAM)

≤ 320 MB

Yes No waveforms (including 
header and marker data)

normal user operation User data is completely sanitized when you 
perform the Erase and Sanitize function.

Persistent 
Memory 
(Flash)

512 MB

Yes Yes all user data User data is completely sanitized when you 
perform the Erase and Sanitize function.

Calibration 
Data 
Memory 
(Flash)

128 kB

No Yes no user data

Table 10-1 Base Instrument Memory  (Continued)

Memory 
Type and 
Size
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Purpose/Contents Data Input Method Location in Instrument and Remarks
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Working in a Secure Environment
Removing Data from Memory (Option 006 Only)
Removing Data from Memory (Option 006 Only)
When moving the signal generator from a secure development environment, there are several security 
functions you can use to remove classified proprietary information from the instrument. Security 
functions also have equivalent SCPI commands for remote operation (“System Subsystem (:SYSTem)” 
commands; refer to the SCPI Command Reference)

CAUTION The signal generator has several memory types (described in Table 10- 1 on page 134, 
and Table 10- 2 on page 135), and each is used to store a specific type of data. Before 
removing sensitive data, understand how each memory type is used.

Erase All

Removes:  All user files, user flatness calibrations, user I/Q calibrations

Resets:   All table editors with original factory values, ensuring that user data and 
configurations are not accessible or viewable

Does Not:  Sanitize memory

Time to Erase:   typically < 1 minute, depending on the number of files.

To Start:  Press File > More > Security > Erase All > Confirm Erase

NOTE This is not File > Delete All Files, which deletes all user files but does not reset table editors.

page 137

Below

See Secure Mode 
on page 137

See 
page 36

For details on each key, 
use key help as described on page 23.
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Working in a Secure Environment
Removing Data from Memory (Option 006 Only)
Erase and Overwrite All

This performs the same actions as Erase All, plus it clears and overwrites the various memory types 
in accordance with Department of Defense (DoD) standards, as follows:

CPU Flash  Overwrites all addressable locations with random characters and then erases the 
flash blocks. This accomplishes the same purpose as a chip erase. System files are 
restored after erase.

To Start:  Press File > More > Security > Erase and Overwrite All > Confirm Erase

Erase and Sanitize All

This performs the same actions as Erase and Overwrite All and then adds more overwriting actions. 
After executing this function, you must manually perform the additional steps described below for the 
sanitization to comply with Department of Defense (DoD) standards.

To Start:  Press File > More > Security > Erase and Sanitize All > Confirm Sanitize

Secure Mode

CAUTION Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease 
the security level; the erasure actions for that security level execute at the next power 
cycle. Once you activate secure mode, you can only increase the security level until you 
cycle power. For example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but secure mode is 
not activated.

Secure mode automatically applies the selected Security Level action the next time the instrument’s 
power cycles. 

To Set the Level:  Press File > More > Security > Security Level and choose from the following:

— None = factory preset, no user information is lost
— Erase = Erase All
— Overwrite = Erase and Overwrite All
— Sanitize = Erase and Sanitize All

To Activate:  Press File > More > Security > Enter Secure Mode > Confirm

The softkey changes to Secure Mode Activated.

CPU Flash Overwrites all addressable locations with random characters and then erases the 
flash blocks. This accomplishes the same purpose as a chip erase. System files 
are restored after erase.

BBG Persistent 
Memory (Flash)

(Vector instruments only) Overwrites all addressable locations with random 
characters and then erases the flash blocks. This accomplishes the same purpose 
as a chip erase. System files are restored after erase.
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Working in a Secure Environment
Removing Data from Memory (Option 006 Only)
Securing a Nonfunctioning Instrument

If the instrument is not functioning and you are unable to use the security functions, you must 
physically remove the processor board and, for vector instruments, the A4 Memory Chip from the 
instrument. Once these assemblies are removed, choose one of the following options:

• Discard the board (or boards) and send the instrument to a repair facility. A new board (or 
boards) will be installed and the instrument will be repaired and calibrated. If the instrument is 
still under warranty, you will not be charged for new boards.

• If you have another working instrument, install the board (or boards) into that instrument and 
erase the memory. Then reinstall the board (or boards) back into the nonworking instrument and 
send it to a repair facility for repair and calibration. If you discover that one or both of the 
boards do not function in the working instrument, discard the nonfunctioning board and note on 
the repair order that it caused the instrument failure. If the instrument is still under warranty, 
you will not be charged for new boards.

For instructions on how to remove and replace boards, refer to the Service Guide.
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Working in a Secure Environment
Using the Secure Display (Option 006 Only)
Using the Secure Display (Option 006 Only)
This function prevents unauthorized personnel from reading the instrument display and tampering 
with the current configuration through the front panel. The display blanks, except for the message 
shown in the following figure, and the front panel keys are disabled. 

To re- enable the display and front panel keys, cycle the power.

Figure 10-1 Secure Display Softkeys
For details on each key, use key help
as described on page 23.
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Working in a Secure Environment
Using the Secure Display (Option 006 Only)
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11 Troubleshooting

• Display on page 142

• Signal Generator Lock- Up on page 142

• RF Output on page 143

— No RF Output
— Power Supply Shuts Down
— No Modulation at the RF Output
— RF Output Power too Low
— Distortion
— Signal Loss While Working with a Spectrum Analyzer
— Signal Loss While Working with a Mixer on page 144

• Sweep on page 146

— Cannot Turn Off Sweep
— Sweep Appears Stalled
— Incorrect List Sweep Dwell Time
— List Sweep Information is Missing from a Recalled Register
— Amplitude Does Not Change in List or Step Sweep on page 146

• Internal Media Data Storage on page 147

— Instrument State Saved but the Register is Empty or Contains the Wrong State

• External Media Data Storage on page 147

— Instrument Recognizes External Media Connection, but Does Not Display Files

• Preset on page 147

— The Signal Generator Does Not Respond
— Pressing Preset Performs a User Preset

• Error Messages on page 148

• Front Panel Tests on page 149

• Self Test on page 149

• Licenses on page 150

• Contacting Agilent Technologies on page 151

— Returning a Signal Generator to Agilent
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Troubleshooting
Display
Display

The Display is Too Dark to Read

Both brightness and contrast may be set to minimum. Use the figure in “Display Settings” on page 16 
to locate the brightness and contrast softkeys and adjust their values so that you can see the display.

Signal Generator Lock-Up
• Ensure that the signal generator is not in remote mode (the R annunciator shows on the display). 

To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

• Ensure that the signal generator is not in local lockout, which prevents front panel operation. For 
information on local lockout, refer to the Programming Guide.

• If a progress bar appears on the signal generator display, an operation is in progress.

• Preset the signal generator.

• Cycle power on the signal generator.
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Troubleshooting
RF Output
RF Output

No RF Output
• Check the RF ON/OFF LED (shown on page 3). If it is off, press RF On/Off to turn the output on.

• Ensure that the amplitude is set within the signal generator’s range.

• If the instrument is playing a waveform, ensure that marker polarity and routing settings are 
correct (see “Saving Marker Polarity and Routing Settings” on page 83).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the 
instrument, send the signal generator to an Agilent service center for repair (see page 151).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are on. 
See also, page 34.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on (the 
I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating 
within the signal generator’s specified limits.

RF Output Power too Low
• If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:

Press Amptd > More (1 of 2) > Amptd Offset > 0 > dB. See also, “Setting an Output Offset” on page 49.

• If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:

1. Press Amptd > More > Amptd Ref Off On until Off highlights.

2. Reset the output power to the desired level.

See also, “Setting an Output Reference” on page 50.

• If you are using the signal generator with an external mixer, see page 144.

• If you are using the signal generator with a spectrum analyzer, see page 144.

• If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically 
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display 
the sequence header information and recalculate the RMS value (see page 78).
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Troubleshooting
RF Output
Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the RF output when you use the signal 
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating mode 
(described on page 47).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some 
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than 
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF output. 
The rate of the undesired AM equals the difference in frequency between the spectrum analyzer’s LO 
feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes. 

See:

• “ALC Off Mode” on page 47

and

• “Power Search Mode” on page 48

Signal Loss While Working with a Mixer

To fix signal loss at the signal generator’s RF output during low- amplitude coupled operation with a 
mixer, add attenuation and increase the RF output amplitude.

The figure at right shows a 
configuration in which the 
signal generator provides a 
low amplitude signal to a 
mixer.

The internally leveled signal 
generator RF output (and ALC 
level) is −8 dBm. The mixer is 
driven with an LO of +10 dBm 
and has an LO- to- RF isolation 
of 15 dB. The resulting 
−5 dBm LO feedthrough 
enters the signal generator’s 
RF output connector and 
arrives at the internal 
detector.

Depending on frequency, it is 
possible for most of this LO 
feedthrough energy to enter the detector. Because the detector responds to its total input power 
regardless of frequency, this excess energy causes the ALC to reduce the RF output. In this example, 
the reverse power across the detector is actually greater than the ALC level, which can result in loss 
of signal at the RF output.

Mixer

LO 

ALC Level 
= −8 dBm

RF Level 
Control

Signal Generator
Output Control

Detector 
measures 
−8 dBm
ALC level

Detector 
measures 
−5 dBm
reverse 
power

LO Feedthru
= −5 dBm

RF Output
= −8 dBm

LO Level
= +10 dBm

IF 

Effects of Reverse Power on ALC
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Troubleshooting
RF Output
The solution at right shows a 
similar configuration with the 
addition of a 10 dB 
attenuator connected between 
the RF output of the signal 
generator and the input of 
the mixer. The signal 
generator’s ALC level 
increases to +2 dBm and 
transmits through a 10 dB 
attenuator to achieve the 
required −8 dBm amplitude 
at the mixer input. 

Compared to the original 
configuration, the ALC level 
is 10 dB higher while the 
attenuator reduces the LO 
feedthrough (and the signal 
generator’s RF output) by 10 
dB. Using the attenuated 
configuration, the detector is exposed to a +2 dBm desired signal versus the −15 dBm undesired LO 
feedthrough. This 17 dB difference between desired and undesired energy results in a maximum 
0.1 dB shift in the signal generator’s RF output level.

Mixer

LO 

ALC Level/ 
RF Output
= +2 dBm

RF Level 
Control

Signal Generator
Output Control

Detector 
measures 
+2 dBm
ALC level

Detector 
measures 
−15 dBm
reverse 
power

LO Feedthru
= −5 dBm

RF Output
= −8 dBm

LO Level
= +10 dBm

IF 

Reverse Power Solution

10 dB 
ATTEN
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Troubleshooting
Sweep
Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see 
“Configuring a Swept Output” on page 27). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq
Sweep > Sweep > Amptd
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey. 

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too 
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time
1. Press Sweep > More > Configure List Sweep.

2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them.
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step 
sweep rather than list sweep.

See also, “Configuring a Swept Output” on page 27.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. 
Only the current list sweep is available to the signal generator. You can store list sweep data in the 
instrument catalog (see “Saving and Recalling Data” on page 37).

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep 
type is set to frequency (Freq) or waveform.
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Troubleshooting
Internal Media Data Storage
Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State

If the register number you intended to use is empty or contains the wrong instrument state, recall 
register 99. If you selected a register number greater than 99, the signal generator automatically saves 
the instrument state in register 99.

See also, “Working with Instrument State Files” on page 38.

External Media Data Storage

Instrument Recognizes External Media Connection, but Does Not Display Files

If the external media works on other instruments or computers, it may simply be incompatible with 
the signal generator; use a different memory stick. See the signal generator data sheet for information 
on compatible media.

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which 
locks the keypad. 

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward- compatible SCPI command. To return the signal 
generator to normal use, send the command :SYST:PRESet:TYPE NORM. 

For information on SG−1364/U SCPI commands, refer to the SCPI Command Reference.
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Error Messages
Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query 
error does not generate a device- specific, execution, or command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue control has detected a 
problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this class 
set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors 
correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

• Either an attempt is being made to read data from the output queue when no output is either 
present or pending, or

• data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate that a device operation 
did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes 
are also used for self- test response errors. Errors in this class set the device- specific error bit (bit 3) 
in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that 
the instrument detected an error within the GPIB system, within the instrument’s firmware or 
hardware, during the transfer of block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by the instrument’s 
execution control block. Errors in this class set the execution error bit (bit 4) in the event status 
register (IEEE 488.2, section 11.5.1). In this case:

• Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of 
its legal input range or is otherwise inconsistent with the device’s capabilities, or

• a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. 
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser detected an IEEE 488.2 
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE 
488.2, section 11.5.1). In this case:

• Either an IEEE 488.2 syntax error has been detected by the parser (a control- to- device message 
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data 
element that violates device listening formats or whose type is unacceptable to the device.), or

• an unrecognized header was received. These include incorrect device- specific headers and 
incorrect or unimplemented IEEE 488.2 common commands.

Error Message File

A complete list of error messages is provided on the CDROM supplied with the instrument. In the 
error message file, an explanation is generally included with each error to further clarify its meaning. 
The error messages are listed numerically. In cases where there are multiple listings for the same 
error number, the messages are in alphabetical order. 
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Front Panel Tests
Front Panel Tests

Self Test
The self test is a series of internal tests that checks different signal generator functions.

Set all display pixels to the selected color. 
To return to normal operation, press any key.

Blink RF On/Off, Mod on/Off, and More LEDs

Correct operation:
Full CCW = −10
Full CW = 10

Displays a keyboard map. 
As you press a key, the map indicates the key location.

For details on each key, use key help
as described on page 23.

It takes about 5 minutes to run the self test.

If a failure occurs:
1. Ensure that all external cables, including GPIB, LAN, and 

USB cables, are disconnected from the signal generator and 
perform the self-test again.

2. If the self-test continues to fail, the signal generator requires 
service. If you are unable to service the instrument, send the 
signal generator to an Agilent service center for repair, with 
a detailed description of the failed test(s) and any other error 
messages that appeared on the display.

Refer to “Contacting Agilent Technologies” on page 151.

Displays the details of the 
currently selected test.
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Licenses
Licenses

A Time-Based License Quits Working
• The instrument’s time or date may have been reset forward causing the time- based license to 

expire.

• The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time- based licenses.

See page 18 for details and cautions on setting time and date.

Cannot Load a Time-Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time- based licenses.

See page 18 for details and cautions on setting time and date.
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Contacting Agilent Technologies
Contacting Agilent Technologies
• assistance with test and measurements needs, and information on finding a local Agilent office:

http://www.agilent.com/find/assist

• accessories or documentation: http://www.agilent.com/find/mxg

• new firmware releases: http://www.agilent.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model 
number and full serial number. With this information, the Agilent representative can 
determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent

Use the following steps to return a signal generator to Agilent Technologies for servicing:

1. Gather as much information as possible regarding the signal generator’s problem. 

2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific 
to your geographic location. If you do not have access to the Internet, contact your Agilent field 
engineer. 

After sharing information regarding the signal generator and its condition, you will receive 
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar 
packaging to properly protect the signal generator.
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Contacting Agilent Technologies
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Glossary

A

Active Entry The currently selected, and 
therefore editable, entry or parameter

ARB Arbitrary waveform generator

AWG Arbitrary waveform generator. Additive 
white Gaussian noise

B

BBG Media Baseband generator media. Volatile 
memory, where waveform files are played or 
edited.

BNC Connector Bayonet Neill- Concelman 
connector. A type of RF connector used to 
terminate coaxial cable. 

C

CCW Counterclockwise

C/N Carrier- to- noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 28), the 
time that the signal is settled and you can make 
a measurement before the sweep moves to the 
next point.

E

EVM Error vector magnitude; the magnitude of 
the vector difference at a given instant between 
the ideal reference signal and the measured 
signal.
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GPIB General purpose interface bus. An 8- bit 
parallel bus common on test equipment.

H

Hardkey A labeled button on the instrument.

I

IF Intermediate frequency

Int Media Internal media. Non−volatile signal 
generator memory, where waveform files are 
stored.

IP Internet protocol. The network layer for the 
TCP/IP protocol suite widely used on Ethernet 
networks.

L

LAN Local area network

LO Local oscillator

LXI LAN extension for instrumentation. An 
instrumentation platform based on industry 
standard Ethernet technology designed to 
provide modularity, flexibility, and performance 
to small-  and medium- sized systems. See also, 
http://www.lxistandard.org

P

Persistent Settings (States) Settings unaffected 
by preset, user preset, or power cycle.

Point- to- point Time In a step sweep (see 
page 28), the sum of the dwell time plus 
processing time, switching time, and settling 
time.
153



R

RMS Root mean square. A time- varying signal’s 
effective value (the equivalent DC voltage 
required to generate the equivalent heat across 
a given resistor). For a sinewave, RMS = 0.707 x 
peak value. 

S

Softkey A button located along the instrument’s 
display that performs whatever function is 
shown next to it on that display.

T

TCP Transmission control protocol. The most 
common transport layer protocol used on 
Ethernet and the Internet.

Terminator A unit indicator (such as Hz or 
dBm) that completes an entry. For example, for 
the entry 100 Hz, Hz is the terminator.

Type- N Connector Threaded RF connector used 
to join coaxial cables.

U

USB Universal serial bus. See also, 
http://www.usb.org
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Symbols
# points softkey, 28
# Skipped Points softkey, 87
ΦM

annunciator, 7
dc offset, removing, 55
hardkey, 53
softkeys, 53, 55

Numerics
10 MHz OUT connector, 11
100Base- T LAN cable, 20
628, error, 72
8648A/B/C/D softkey, 19
8656B,8657A/B softkey, 19

A
AC power receptacle, 9
Activate Secure Display softkey, 16
active

entry, 153
entry area, 7
function area, 25

Active High softkey, 99
Active Low softkey, 99
Add Comment To softkey, 38
additive white Gaussian noise. See AWGN
address, GPIB, 19
Adjust Phase softkey, 26
Adjustable doublet softkey, 58
adjustments

I/Q, 64
quadrature, 125

adjustments, I/Q, 125
advance, segment, 101
Advanced Settings softkey, 20
Agilent sales and service offices, 151
ALC

hold, 83, 84
OFF annunciator, 7
off mode, 47
softkeys, 26, 87

AM
annunciator, 7
connector, 9
external source, 55
hardkey, 53
softkeys, 53

amplitude
display area, 8
hardkey, 26
modulation, 53
offset, 49
reference, 50
setting, 26

softkeys, 26–29
troubleshooting sweep, 146

AMPTD hardkey, 26
Amptd softkeys, 26–29
analog modulation, 53
angle, quadrature, 64
annunciators, 7
Apply To Waveform softkey, 87
ARB

definition, 153
player, dual, 68
softkeys, 68, 97, 130
waveform clipping, 105

ARMED annunciator, 7
arrow keys, 24
ATTEN HOLD annunciator, 7
Atten/ALC Control softkey, 26
Auto (DHCP/Auto- IP) softkey, 20
Auto softkey, 47
auto- IP, 20
AUX I/O connector, 13
Auxiliary Software Options softkey, 21
AWGN

adding, 129
annunciator, 7
definition, 153
dual ARB player, 130
softkeys, 132

B
backspace hardkey, 24
Backup All User Files to Current Directory softkey, 41
Bandwidth softkey, 132
baseband, 13

aligning signals at, 83
clipping, 105
frequency offset, setting, 72
I/Q output connectors, 12
memory, 68, 134
noise, 129
noise annunciator, 7
quadrature adjustment, 125
real time I/Q AWGN, 130, 132
softkey, 72
summing signals, 124
waveforms convert to analog, 116

Baseband Frequency Offset softkey, 72
BB GEN, 124
BBG, 124
BBG media, 68, 71, 153
Binary softkey, 35
Bk Sp hardkey, 24
BNC, 153
bootrom memory, 134
Bright Color softkey, 16
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brightness adjustment, 16
Brightness softkey, 16
Buffered Trig softkey, 99
Build New Waveform Sequence softkey, 74, 95
Burst Envelope softkey, 121
Bus softkey, 27

C
C/N, 153
cables, 100Base- T LAN, 20
cables, crossover, 20
Calculate softkey, 78
calibration data, 134
calibration data memory, 135
Calibration Type softkey, 127
calibration, I/Q, 127
Cancel hardkey, 4
carrier

bandwidth, 130
configuring, 26
modulating, 34
to noise ratio, 130

Carrier Bandwidth softkey, 130
carrier feedthrough, 64
Carrier to Noise softkey, 130
Catalog Type softkey, 35, 78
catalog, state files, 40
ccw, 153
Channel Band softkey, 26
Channel Number softkey, 26
circular clipping, 109, 112
classified. See security
Clear Error Queue(s) softkey, 42
Clear Header softkey, 78
Clear Text softkey, 24
clipping

circular, 109, 112
rectangular, 110, 113
softkeys, 105

clock, sample rate, 13
color palette, display, 16
comments, adding & editing (instrument state), 38
Config Type softkey, 20
Configure softkeys

Cal Array, 44
List Sweep, 27, 29
Step Array, 44
Step Sweep, 27, 28

Connection Monitoring softkey, 20
connectors

external triggering source, 102, 104
front panel, 3
rear panel, 9
routing signals, 33

Continuous softkey, 99

continuous step sweep example, 32
continuous wave output, 26
contrast adjustment, 16
Contrast softkey, 16
Copy File softkey, 35
correction array (user flatness), 45

See also user flatness correction
crossover cable, 20
cursor, 25
cw, 153
CW (no modulation) softkey, 29

D
DAC over range error, 72
DAC over- range error, 116
DAC over- range errors, 116
Dark Color softkey, 16
data

calibration, 134
entry softkeys, 24
erasing, 136
files, 35–38
removing, 136
serial, synchronizing, 13
storage

comments, adding and editing, 38
troubleshooting, 147
type, 41
using, 35

date, setting, 18
dc offset, 64
dc offset, removing, 55
DCFMΦ/DCfM Cal softkey, 53
Default Gateway softkey, 20
default settings

restoring, 17
system, restoring, 23

defaults, restoring, 20, 127
delay, I/Q, 125
Delete Row softkey, 29
Delete softkeys

All, 35
All Files In Current Directory, 41
All Regs in Seq, 38
All Segments On Int Media, 70
All Sequences, 38
All Waveforms, 74
All Waveforms softkey, 95
File, 35
File or Directory, 36, 41
Item, 25, 29
Row, 25
Selected Waveform, 74, 95
Seq Reg, 38
Waveform Sequence, 95
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DETHTR annunciator, 7
Device softkey, 26
DHCP, 20, 153
DHCP softkey, 20
Diff Mode softkeys, 125
DIGBUS annunciator, 8
digital bus, 13
digital operation, 67
digital signal to analog waveform, 116
display

blanking, 139
error message area, 8
overview, 3, 7
secure, 139
settings, 16
softkey labels, 8
tests, 149
text area, 8
troubleshooting, 142

display memory, 134
Display softkey, 15
Display Waveform And Markers softkey, 87
Displayed Case softkey, 24
distortion, troubleshooting, 143
DNS Server Override softkey, 20
DNS Server softkey, 20
documentation, ix
Domain Name softkey, 20
doublet softkeys, 58
doublet, adjustable, 60
doublet, trigger, 60
Dual ARB

player, 68
softkeys, 69

dual ARB real- time noise, 130
Dual ARB softkey, 130
dwell time, 29, 153
Dwell Type softkey, 29
dwell, troubleshooting, 146
Dynamic DNS Naming softkey, 20
Dynamic Hostname Services softkey, 20

E
Edit softkeys

Noise RMS Override, 78
Repetitions, 95
RMS, 78
Selected Waveform Sequence, 74, 95

Editing Keys softkey, 24
Editing Mode softkey, 24
editor, table, 25
EEPROM, 134
Enable/Disable Markers softkey, 74, 95
entry, active, 153
ERR annunciator, 8

Error hardkey, 42
error messages, 42

display area, 8
file, 148
message format, 42
types, 148

errors
DAC over range, 72
DAC over- range, 116

Esc hardkey, 4
EVENT

connector, AUX I/O, 13
connector, BNC, 12, 82
output jitter, 97
outputs, 82

EVM, 153
EVM error, 64
Execute Cal softkey, 127
EXT CLOCK connector, 12
EXT REF annunciator, 7, 8
Ext softkeys

Delay, 100
Delay Time, 100
Ext, 27
I/Q Output, 121, 122, 123
Pulse, 58
Source, 100

external
I and Q signals, 124
media, 41, 147
modulation source, 55
trigger source, 102, 104
triggering, 104

External Media Not Detected message, 41
External softkeys

External, 121
Input, 125
Input I Offset, 64
Input Q Offset, 64
Media File Manager, 35
Output, 125

F
factory defaults, restoring, 17, 20, 127
features, 2
feedthrough, 64
file catalog. See data storage
File hardkey, 35, 40
file headers

creating, 78
editing, 79
example, 79
viewing a different file, 81

files. See data
filter, interpolator, 116
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firmware

memory, 134
upgrading, 18

firmware, upgrading, 151
First Mkr Point softkey, 87
First Sample Point softkey, 87
flash memory, 134
flatness correction. See user flatness correction
Flatness softkey, 44
FM

annunciator, 8
connector, 10
dc offset, removing, 55
external source, 55
hardkey, 53
softkeys, 53

Free Run softkey, 27, 99
Free- Run softkey, 58
FREQ hardkey, 26
Freq softkeys, 26–29, 44
frequency

display area, 7
hardkey, 5, 6, 26
modulation, 53
multiplier, 51
offset, 49
offset, baseband, 72
offset, setting, 72
reference, 50
setting, 26
softkeys, 26, 26–29

front panel
disabling keys, 139
display, 7
I/Q inputs, using, 65
knob resolution, 17
overview, 3
tests, 149

front panel memory, 135
FTP server, 20
FTP Server softkey, 20
fundamental operation See basic operation

G
Gated softkey, 58, 99
gated triggering, 99, 102
Gaussian. See AWGN
glossary, 153
Go To Default Path softkey, 36, 41
Goto Row softkey, 25, 29, 35
GPIB

connector, 11
definition, 153
setup, 19

GPIB Address softkey, 19

GPIB Setup softkey, 19
green LED, 6
guides, content of, ix

H
hardkeys

definition, 153
help on, 23
overview, 3
See also specific key

header utilities softkeys, 78
Help hardkey, 4, 23
Hostname softkey, 20
hostname, setting, 20

I
I connector, 5
I Offset softkey, 125
I OUT connector, 12
I/O Config softkey, 15
I/Q

adjustments, 125
front panel inputs, using, 65, 124
modulation, 121
optimizing, 122
rear panel outputs, 12
rear panel outputs, using, 122
signal path, optimizing, 122
signal, aligning, 83
softkeys, 64, 121–127
waveform, clipping, 105

I/Q adjustments, 64
I/Q modulation, 64
IF, 153
images, 64
impairments, 64
Import Waveform softkey, 95
Incr Set hardkey, 6
information, removing from memory, 136
Insert softkeys

Insert, 74
Item, 25, 29
Row, 25, 29
Waveform, 74
Waveform Sequence Contents, 74

installation guide content, ix
instrument firmware, upgrading, 18
Instrument softkeys

Adjustments, 15
Info, 15
Options, 21

instrument state
associating with waveform, 38
files, 38, 40
register. See data storage
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int media, 153
Int Phase Polarity softkey, 121
interface

GPIB, 19
LAN, 20

Internal Baseband Adjustments softkey, 125
internal media, 41
interpolator filter, 116
IP

Address softkey, 20
address, setting, 20
auto, 20
definition, 153

J
jitter on EVENT output, 97

K
keys

disabling, 139
front panel, 3
help on, 23
numeric, 3
test, 149
See also specific key

knob, 6, 17, 24

L
L annunciator, 8
LAN

connector, 11
definition, 153
Services Setup softkey, 19
setup, 20
Setup softkey, 19

Last Mkr Point softkey, 87
Last softkey, 17
LCD display memory, 134
LEDs, 6

blink test, 149
front panel, 6
modulation, 34

leveling, turning off, 47
licenses

manager, 21
service software, 21
signal studio, 21
time- based, 18
troubleshooting, 150
viewing, 21
waveform, 21

line power (green) LED, 6
linear sweep, 28
list mode values, 30
List softkey, 35

list sweep
parameters, 30
status information, 30
troubleshooting, 146
using, 29
waveform, 31

listener mode annunciator, 8
LO, 153
Load softkeys

All From Int Media, 70
Cal Array From Step Array, 44
From Selected File, 37
Load/Store, 29, 37
Segment From Int Media, 70
Store, 70

Local hardkey, 4
lock up, troubleshooting, 142
logarithmic sweep, 28
LXI, 153

M
main memory, 134
manual control, sweep, 33
Manual softkeys

Config Settings, 20
Manual, 20
Mode, 27
Point, 27

manuals, content of, ix
Marker softkeys, 87
markers

signal, aligning, 83
markers, waveform, 82–97
media

BBG, 153
erasing, 136
int, 153
memory stick, 41
storage, 41
types, 68, 134
USB, 41, 147

memory, 134
erasing data from, 136

memory. See media
menu keys, 4
messages, error, 148
mixer, troubleshooting signal loss, 144
Mod On/Off hardkey, 5, 34
Mode hardkey, 69, 130, 132
modulation

AM, 53
annunciators, 8
carrier signal, 34
external source, using, 55
FM, 53
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generating, 34
I/Q, 64, 121
phase, 53
pulse, 57
troubleshooting, 143

Modulator Atten softkey, 132
monochrome display, setting, 16
Monochrome softkey, 16
MULT annunciator, 8
multiplier, using, 51

N
Name And Store softkey, 95
No Retrigger softkey, 99
noise, 129
noise bandwidth factor, 130
Noise softkeys, 130
non- volatile memory, 68
Non- Volatile Segments softkey, 35, 78
number keys, 24
numeric keypad, 3

O
OFFS annunciator, 8
offset, 64
offsets

baseband frequency, 72
I/Q, 125
output, using, 49

on/off switch, 6
operation, basic, 23
operation, remote, 19
optimization, I/Q, 64, 121
options

enabling, 15, 21
resource, 2

Options Info softkey, 21
Output Blanking softkey, 26
output, swept, 27
over- range errors, DAC, 116
overshoot, 116
overview, signal generator, 1

P
Page Up hardkey, 4
parameters, saving a waveform’s, 78
path delay, 64
PATT TRIG IN connector, 13
Patt Trig In softkeys, 100
peak- to- average power, reducing, 109
performance, optimizing, 43
persistent memory, 135
persistent settings

definition, 153
resetting, 23

restoring defaults, 17
Phase Ref Set softkey, 26
phase skew, 64
pixel test, 149
Plot CDDF softkey, 115
Point Trigger softkey, 27
point- to- point time, 153
polarity, external trigger, 100
polarity, marker, setting, 94
power

meter, 44, 45
on, settings, 17
peak- to- average, reducing, 109
receptacle, 9
search, 48
setting, 26
softkeys, 15, 17, 26–29, 47
supply, troubleshooting, 143
switch, 6
troubleshooting, 143

Power softkeys
On, 17
On/Preset, 15
Search, 47

preferences, setting, 15
preset

hardkey location, 4
settings, 17
troubleshooting, 147
using, 23

Preset softkeys
Language, 17
List, 29, 44
Preset, 17

Proceed With Reconfiguration softkey, 20
programming guide content, ix
pulse

annunciator, 8
characteristics, 59
connector, 10
marker, viewing, 92
modulation, 57
narrow, 47
sync signal, 33
video signal, 33

Pulse hardkey, 58
Pulse softkeys, 33, 58
Pulse/RF Blank softkey, 87

Q
Q connector, 5
Q Offset softkey, 125
quadrature adjustment, 125
quadrature angle, 64
Quadrature Angle Adjustment softkey, 64, 125
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queue, error, 42

R
R annunciator, 8
RAM, 134, 135
Real Time I/Q Baseband AWGN softkeys, 132
real- time noise, 130
Real- time Noise softkeys, 130
rear panel

I/Q outputs, 122
rear panel overview, 9
Recall hardkey, 38
recall register, troubleshooting, 146
rectangular clipping, 110, 113
REF annunciator, 8
REF IN connector, 10
Ref Oscillator Source softkey, 26
reference, using, 50
references, content of, ix
regrowth, spectral, 108
Remote Language softkey, 19
remote operation annunciator, 8
remote operation preferences, 19
Rename File softkey, 35
Rename Segment softkey, 70
Reset & Run softkey, 99
Restart on Trig softkey, 99
Restore softkeys

All User Files from Current Directory, 41
LAN Settings to Default Values, 20
System Settings to Default Values, 17

Return hardkey, 6
Reverse Power Protection softkey, 17
Revert to Default Cal Settings softkey, 127
RF

blanking
marker function, 93
settings, saving, 83

hardkey, 5
output

configuring, 26
connector, 5
troubleshooting, 143

RF During Power Search softkey, 47
RF Output softkey, 121, 122, 123
RFC NETBIOS Naming softkey, 20
ringing, 116
ripple, 116
RMS, 154
rotary knob, 24
Route Connectors softkey, 27, 58
Route To softkeys, 33, 58
routing

I/Q, 64, 121
marker

ALC hold, 84
RF blanking, 93
saving settings, 83

RPG test, 149
runtime scaling, 118

S
S annunciator, 8
sales, Agilent offices, 151
sample rate clock, 13
sample rate softkey, 97
Save hardkey, 38
SAVE Seq Reg softkey, 38
Save Setup To Header softkey, 78
Scale Waveform Data softkey, 115
scaling softkeys, 115
SCPI

enabling, 20
reference content, ix
softkey, 19

screen saver settings, 16
Screen Saver softkey, 16
search, power, 48
secure

display, 139
mode, 137
softkey, 35

security, 133
Security softkey, 35
Segment Advance softkey, 99
segment advance triggering, 99
segments

advance triggering, 101
file headers, 78
loading, 71
softkeys, 70
storing, loading, & playing, 70

Select hardkey, 24
Select softkeys

Color Palette, 16
Different Header, 78, 81
Header, 78
Reg, 38
Seq, 38
Waveform, 29

self test, 149
Sequence softkey, 35, 78
sequences

editing, 76
file headers, 78
marker control, 95
playing, 77
waveform, 74

serial data
synchronizing, 13
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server, enabling, 20
service

Agilent offices, 151
guide content, ix
request annunciator, 8

Set Marker softkeys, 87
settings, persistent, 153
Show softkeys

Alpha Table, 24
Waveform Sequence, 74
Waveform Sequence Contents, 74, 95

Signal Studio, 2
signal studio licenses, 21
Single softkey, 99
Single Sweep softkey, 27
skew, I/Q, 125
Sockets SCPI softkey, 20
sockets, enabling, 20
softkeys

definition of, 154
help on, 23
label area, 8
location, 3
See also specific key

source settled signal, 33
Source Settled softkey, 33, 58
Span softkey, 47
Span Type softkey, 47
spectral regrowth, 108
spectrum analyzer, troubleshooting signal loss, 144
Square softkey, 58
standby (yellow) LED, 6
State softkey, 35
states, persistent, 153
step array (user flatness), 45

See also user flatness correction
Step Dwell softkey, 28
Step Spacing softkey, 28
step sweep

spacing, 28
troubleshooting, 146
using, 28

Step/Knob Ratio softkey, 17
Storage Type softkey, 36, 41
Store To File softkey, 37
Subnet Mask softkey, 20
Sum softkey, 121
sweep

annunciator, 8
hardkey, 27
linear, 28
list parameters, 30
list status information, 30
logarithmic, 28
manual control, 33

out connector, 9, 33
out signal, 33
softkeys, 27–33, 58
step, 28
troubleshooting, 146
waveform, including, 31

SWEEP hardkey, 27
Sweep softkeys, 27–33, 58
swept output, 27
switch, power, 6
SWMAN annunciator, 8
system defaults, restoring, 17

T
T annunciator, 8
table editor, 25
talker mode annunciator, 8
TCP, 154
TCP Keep Alive softkeys, 20
terminator, 154
test, self, 149
tests, front panel, 149
text area (on display), 8
text entry softkeys, 70
time, dwell, 153
time, setting, 18
time/date reference point, 18
Time/Date softkey, 18
time- based license, troubleshooting, 150
time- based licenses, cautions, 18
Timer Trigger softkey, 27
Toggle softkeys, 95
Trig

in connector, 10
out connector, 10, 33
out signal, 33

trigger
connectors, 10
hardkey, 4
initiating, 4

Trigger softkeys
& Run, 99
Doublet, 58
Key, 27
Out Polarity, 27
Source, 98
Triggered, 58
Type, 98

Triggered softkey, 58
triggering

gated, 99, 102
segment advance, 99
softkeys, 98
waveforms, 98

troubleshooting, 141
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U
UNLEVEL annunciator, 8
unleveled operation, 47
UNLOCK annunciator, 8
Unspecified softkey, 78
Up Directory softkey, 36
Update in Remote softkey, 16
urls, 2, 18, 21, 151
USB

connecting media, 41
definition, 154
device connector, 11
host connector, 3
troubleshooting, 147

Use Current Directory As Default Path softkey, 41
user

documentation content, ix
files, backup and restore, 35
flatness correction, 44
preset, 23
preset, troubleshooting, 147

User softkeys
Current Directory As Default Path, 36
Flatness, 26, 35
Flatness Correction, 44
Span, 47
User, 17

Utility hardkey, 15

V
vector operation, 67
View Next Error Page softkey, 42
View Previous Error Page softkey, 42
volatile memory, 68, 71
Volatile Segments softkey, 35, 78
VXI- 11, enabling, 20
VXT- 11 SCPI softkey, 20

W
Waveform softkeys

Licenses, 21
Runtime Scaling, 115
Segments, 70
Sequences, 74, 95
Utilities, 115
Waveform, 27, 29

waveforms
clipping, 105
file headers, 78
from digital baseband waveform, 116
in a sweep, 31
license, 21
markers, 82, 83
memory, 135
overview, 68

saving instrument state, 38
scaling, 114
segment softkeys, 70
sequence, 74
storing, loading, & playing, 70
triggering, 98

web server, 20
Web Server softkey, 20
WINIT annunciator, 8

Y
yellow LED, 6

Z
Zoom softkeys, 87
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